How to set Maintenance mode in PrestaShop 1.5

After installing your Prestashop 1.5, you may want to set it to maintenance mode so you can begin to build it. This article describes how to set your Prestashop 1.5 store to maintenance mode while still allowing you to view it in normal mode.

To set Maintenance mode in PrestaShop 1.5:

  1. Log into your PrestaShop 1.5 dashboard
  2. From the top menu bar, hover over the Preferences tab and click on Maintenance on the menu.
    preferences-tab-maintenance
  3. From the Preferences : Maintenance page, select the No radio button on the Enable Shop field. Click the Add my IP button in order to set your PrestaShop 1.5 store to allow you to view the site as normal. The rest of the world will see the maintenance screen. Once completed, click the green Save button in the upper right corner of the screen.
    preferences-set-maintenance
  4. Your site should now display normally to you, but to all visitors it will show the maintenance message like the one below.
    preferences-maintenance-logo

    You have now learned how to set your PrestaShop 1.5 store to maintenance mode.

4 Comments

  • My website has been in maintenance mode for a few days, and I have just received an email alert from Google Webmaster Tools.

    “https://mysite.com/: Googlebot can’t access your site

    Over the last 24 hours, Googlebot encountered 81 errors while attempting to access your robots.txt. To ensure that we didn’t crawl any pages listed in that file, we postponed our crawl. Your site’s overall robots.txt error rate is 71.7%.

    You can see more details about these errors in Webmaster Tools.”

    I have searched for help on what to do with googlebots while the site is in maintenance mode but I got completely confused.

    Can anyone help with a step by step procedure to stop the errors, and how to re-enable googlebots once the website is live again?

    I have Prestashop 1.6.0.9 with a custom theme.

    Thanks in advance

    • Hello Wendy,

      Thank you for your question. I found a post in the Google forums, where they advise checking your error logs, or having your host check the error logs.

      If you need our Tech support Team to assist you with reviewing the error logs, please submit a ticket and include the time of the reported issues.

      If you have any further question, please feel free to post them below.
      Thanks,

      John-Paul

  • Hi ,

      I have installed the environment in my local system everything i have successfully completed but the thing is that its always going towards maintainence mode even i tried to make changes from administrator but it doesnt work. please help me……………………!!

      

    • Hello guru,

      Thank you for contacting us. If you are being redirected to maintenance mode, I recommend checking the IP address that you entered. Since it is running on your local system, you may have to use your internal IP, instead of the outside IP.

      If you are using caching in PrestaShop, you may have to disable this while testing maintenance mode.

      Also, you may have to clear your browser cache, before testing this option.

      If you have any further questions, feel free to post them below.
      Thank you,

      -John-Paul

Was this article helpful? Let us know!