0
Answered

Wordpress Site Health says: The optional module, imagick, is not installed, or has been disabled.

mike.mitchell 1 year ago updated by Agware Gideon 3 weeks ago 10 3 duplicates

Other posts say say imagick PHP module is always installed on shared hosting, yet I get this error.  How can it be fixed?

Answer

Answer
Answered

Hello and thanks for contacting us. You can email our Technical Support if you wish to have this installed.

Duplicates 3

+1

I have this installed, but it is still showing in the health check as missing/not installed, is there something else that needs to be done to make Wordpress see it?

Hello RichardC,


Sorry for the message that you're not seeing the Imagick module installed. I would first check your installation with a PHPINFO page to see if the Imagick module actually loaded.  Click on the link to that if you have not already tried it. You can do a ctrl+ F to find the module (there's a lot of information displayed on the PHPinfo page).  If you're seeing the module, then I would recommend what was said on the WordPress forum for this issue - they said to restart the service.  You can see the string by clicking on the link.  I hope that helps to answer your question.  As per our previous answers, it the entire Imagick module is not required for WordPress to operate.  I know it shows up in the Site Health Check feature, but you can see the discussion in the WordPress forum.  By default, our servers generally include the Mogrify and Convert options.  

If you have any further questions or comments, please let us know.


Kindest Regards,

Arnel C.

Arnel,

Following up on this issue, it's a little confusing because Inmotionhostoing states you already have ImageMagick installed and activated on all your servers. If this is true, how would the module not be recognized?

I have the same issue on my VPS with you guys.

Is this not true?

This is likely related to the API's not being loaded as stated in our article: Is ImageMagick installed on my server?

Answer
Answered

Hello and thanks for contacting us. You can email our Technical Support if you wish to have this installed.

Answered

Hello Mike,

Thanks for the question about Imagick on your server.  Actually, it's often not loaded on servers due to the load it can add to servers. However, it is available to be installed for you.  You would need to submit a ticket to InMotion Hosting technical support requesting that it be installed to your account.  If you have any further questions or comments, please let us know.

Kindest regards,

Arnel C.

+1

I'll contact support, but according to https://make.wordpress.org/hosting/handbook/handbook/server-environment/#php-extensions
it is a required extension for Wordpress, so I think In-Motion should install it by default. The site-health.php will report performance degradation without it. 

Just to clarify, as per at least a few moderators in the WordPress community forums, "Imagick" is not required for WordPress.  It does provide extra functionality.  It is often disabled on hosting servers but it can be added as needed.  

References (WordPress Community Support pages):

I am planning to write an article on the issue that will explain the issue in further detail.  For now, your ticket will resolve the problem of getting the imagick module installed on your server.  

If you have any further questions or comments, please let us know.


Kindest regards,

Arnel C.

Answered

I had this same issue on my site TECTEEM. I cant seem to install any plugins. Ive fixed the issue. I found out the issue was from the hosting provider. Just chat your hosting provider concerning the issue.

Hello Jesseh, Imagick - refers to the ImageMagick extension for PHP. This extension is already installed on the server. You can find more information on this issue by going to this article: Imagick installed? If you have any further questions, please contact technical support or leave a comment at the bottom of the page. Regards, Arnel C.