May need to change file permissions

  • Answered
(I entered this questions in the comments of the article "Changing File Permissions" but that hasn't been answered, so I'm trying this way.)

I think I need to change my file permissions, b/c I tried to make a widget inactive today and it wouldn't take -- then I saw I had emails saying my firewall prevented a potential attack. I couldn't use the whitelist link in the email because I didn't "have the permission" to do so.

The widgets.php file's permissions are set to 644. This seems to be the problem, b/c it doesn't allow me to execute. But I'm kind of guessing.

I was able to add the widget. I can't understand why I can't deactivate it or delete it.

What would I change the permission to so I can successfully delete this widget and still be safe? (my site was definitely attacked this morning b/c I had about 40 alerts of an executable file upload, so I don't want to leave myself too vulnerable.)

Hello Monica, 644 permissions are settings that allow read/write for the owner and read for everyone else. That should allow you to edit the widgets.php file from within the wp-admin dashboard. Also, when you are logged into the cpanel, you can delete anything you need to from within the File Manager. If you are familiar with the code you need to delete, you may want to try that method. I hope this answers your question. If you have any more questions or information specific to the issue please leave a comment below so we can further assist you. Best Regards, Scott M