How do I enable WebDav support on my server?

Avatar
  • Answered
How do I enabled WebDav support for php on a virtual host? I'm trying to access SabreDav via Cyberduck. SabreDav works, but the first PROPFIND request fails with a 501 error.

I've found that Apache is configured only for GET, HEAD, POST and OPTIONS, and so WebDav will not work.

In the documentation I found the php setting allow_webdav_methods, but this was removed in php 4.3.2 (and never implemented as far as I can tell).

I am aware that using webdisk I can access the root directory, but this is going via cPanel rather than Apache, and limits flexibility.

I've also tried in the .htaccess to allow PROPFIND etc, but it seems that the real problem is that webdav is not enabled in apache. In this case dav should be enabled in httpd.conf, and the disabled for all loctions/directories. Then webdav can be enabled with something like:


Limit PROPFIND MOVE OPTIONS PUT COPY DELETE
order deny,allow
allow from all
Limit


This works on another host. Brackets are missing as they don't seem to be allowed on this forum.
Avatar
Tim S.
Hi dstevens,

Thanks for posting your question. I'm more than happy to assist you. You'll need to email [email protected] and one of our systems administrators can look into getting WebDav set up on your VPS account.

When you email [email protected] please be sure to include the last four digits of the credit card or the current AMP password.

If you need further assistance please feel free to contact us.

Thanks!

Tim S