how ad I make my main page appears when typing the domain name

  • Answered
I made an html main page linked to other html pages on my hard disk using dreamweaver and I saved the images in different directories. all the html pages and the images directories are saved under one directory named "perfume". then I got connected to my FTP host (which I registered) using filezilla and the connection was successful. then I uploaded the one whole directory containing the pages and images into the root directory in filezilla (when I got connected to my host there was no directories, only the root "/"). but still when I try opening my page by typing "" in the browser I don't get the page I designed. so I entered file manager in control panel. the folder named "perfume" which contains the files is saved under /public_html./lona303 the main page is now under /public_html/lona302/perfume. to reach to the main page I should type "" in the browser. how can I get to reach the main page typing only "" in the browser? I tried placing the main page on /public_html/ which is the root public folder, but still, this time to reach the main page I should type in the browser "" , how can I get to the main page tuping only the domain name in the browser? please help
Hello lona302, I'm sorry you're having trouble uploading your site files. I've made a few changes for you so your site will load at now. Since public_html is your document root, you want to make sure your site files (and any subfolders) are uploaded there. I tried moving all of your files and folders to be just under the public_html folder, but it appears you were making changes while I was assisting you with your question. Please move all of your site files and folders directly inside public_html. Please also keep in mind when requesting assistance that if you are making changes while we are troubleshooting, it can interfere with the process of resolving the issue as quickly as possible. The reason your main page was not showing up even when it was placed just inside public_html is because of the name: main.htm. By default, the server looks for index pages to serve as the main page (index.htm, index.html, then index.php). This is called the Directory Index. This default behavior can be overridden by adding the following code to your .htaccess file so that your main.htm page will be shown as your site's main page: DirectoryIndex main.html Since you are using Dreamweaver to create your site, you may find it easier to use the built-in FTP publishing in Dreamweaver. For information on how to set that up and publish your site from Dreamwever, please see our articles on How to configure server settings in Dreamweaver and How to publish your website from Dreamweaver. Please let us know if you have any additional questions or need further assistance. Regards, Christi N.