Jetpack not working with my Wordpress site

  • updated
  • Answered
Hi there,
JetPack is not connecting to my site ( It says the site can not be accessed. I've worked my way through the troubleshooting document that Wordpress supply for this situation here - . Nothing helped.

Then went through the JetPack Debugger . That indicated that -

"Communication error
We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your account. If the error persists, try disconnecting and connecting Jetpack again." . I tried disconnecting and reconnecting as advised but that didn't fix the problem.

Then I look at the error messages page here - . And found this one relating to XML-RPC

This error is possibly a misconfiguration in lighttpd. There are some suggestions at this forum thread: “JetPack Instl issue with SSL and lighttpd“.
In a properly set up site, should show “XML-RPC server accepts POST requests only” and should show some XML."

Both those URLs when run against my server show the line “XML-RPC server accepts POST requests only” - indicating there is a problem with the lighttpd configuration.

If you look at the links they mention and it suggests there is a problem with the rewrite rules and gives some guidence on what you can do to fix them.

Problem is I have no idea what lighttpd rewrite rules are or how to change them, which means I definitely shouldn't be trying to touch them :-)

Can you help with this?

Thanks, Jamie
Arnel C
Quote from kamlesh gamit

I could not connect jet pack to WordPress site hindidroidblog

Hello Kamlesh,

We would need more information concerning issues in order to try to troubleshoot the issue.  You may also want to contact Jetpack support directly for assistance from the developers of the plugin. 

If you have any further questions or comments, please let us know.

Kindest Regards,

Arnel C.

Arnel C

Just as an FYI for LIGHTPPD users:

You can find one solution from this post:Lighttpd url.rewrite for latest WordPress Jetpack.

And, if you follow the support link, you can see another approach to a solution (this is the same link as mentioned in the reply above. If you follow the text thread they provide a solution towards the bottom : Jetpack Instl issue with SSL and lighttpd

kamlesh gamit

I could not connect jet pack to WordPress site hindidroidblog

Tim S.
Good morning Jamie,

Thanks for your question about Jetpack being unable to communicate with WordPress. So, we don't use Lighttpd on our servers, so it's not that. Typically, when we see these errors it's due to Mod_Security blocking the RPC request. In this instance, I'd suggest reaching out to support so we can troubleshoot this further for you. Support is available 24/7/265 by phone, email, and live chat.


Tim S