Very slow website after SSL installation | problems

  • Answered

After a quick chat with the support, the recommended option for me was to buy the SSL via CloudFlare because that's where the domain name is pointed. Although, I installed the certificate on the server via cPanel, otherwise it wouldn't recognize it.

After all that, I notice on GTmetrix that my website was up in load time by 900% (like 2 sec to 20 sec). It seems that one request is bugging the site and don't load properly. I ask the CloudFlare community, nothing. At last resort, I hope you can help me fix that. I really need that SSL, but I may have configured the all thing wrong.

Error is called GET 522 ()

I don't know what to do about it. I try to disable SSL (worst thing to do). Disable Rocket Loader from CloudFlare, disable all plugin one by one. Nothing will do.

Please help me, going crazy with that.

Tim S.

Thanks for your question about your website loading slow after installing an SSL. When I visit this: I see that the host is offline. It's likely taking so long to load as this script is waiting to time out. Also, you have an unusually high number of page requests (148) which is a large amount of data (2.44MB). I'd suggest looking at ways to reduce the number of requests. Since it took about 15 seconds for that particular URL to fail, that's a large part of the 22 sec load time. What is that script you are calling on your website? Is the script somewhere else you can make the get request to, to retrieve it?

I hope this helps!


Tim S