" There was a problem with reindexing process your category products"

  • Answered
Hello, I am building a site in Magento 1.9 and this is my first time doing so. After instilling a template from TempleMonster and changing the demo content to look the way I wanted I ended up getting a "reindexing error with my category products". I have already tried:
1.) changing the Root Category to Default Category inside Magento Config.
2.) I changed my .htaccess to ini_set('memory_limit','2048M');
3.) My Var/ folder doesn't have a lock folder, plus I have changed the Var permissions to both 755 and 777 to see if it would change and nothing happened.

Now I haven't tried to "php shell/indexer.php --reindex" because I am not too sure how to do it since I haven't really worked in Terminal. Plus I read that reindexing your SQL database can cause more problems?

What are some ways can I fix this error? I am not very comfortable with working in terminal and SQL but I feel like that is going to be the only way to fix this.

the site I am currently working on is at fuelhair.com/dev and on that homepage under the "new products" only two show and I need 6 to show but this is where the reindexing error is happening.

Hello, Thank you for your question regarding reindexing issues in Magento. This error appears to be unfortunately lacking in much detail. It doesn't say much about where the issue is occuring or in what file. Checking for PHP errors by enabling error reporting may help for troubleshooting. As an alternative to using the reindexer on the command line, there is a forum topic that illustrates a method for getting more information out of this error. If that fails, I suggest reinstalling and attempting to install the template again. Best, Christopher M.