Problem Restoring Akeeba Backup Of Joomla Site

  • updated
  • Answered

I'm trying to test out the backup and restore process for a sample Joomla site to make sure I understand how to do it if I need to. I installed a Joomla 3.4.8 system, installed Akeeba, created the backup, ftp'd the backup to my local computer (binary), moved that file to the server under ./public_html. I changed the permissions on the file (777, just to be sure). I downloaded the latest kickstart.php from Akeeba's web site. I moved that file to the same directory as the backup. I have tried changing and not changing permissions on the php file, both with the same result. When I navigate to my site address in my browser, The page displays as expected, but the archive file is not available for selection. Based on everything I've seen, all solutions point to permission issues. I have tried opening up ./public_html, as well as freeing up the archive file and the php file. No combination I've tried has resulted in getting beyond the message " No archives detected. Click here for troubleshooting instructions. " Any help is appreciated. I have not found any existing support documentation that addresses this issue for inmotion.

Duplicates 1
Restore del sito dopo un backup - Restore a backup of the site after
Si leggono molti consigli su come fare un backup con Akeeba Backup, ma non rtovo suggerimenti su come ripristinare il sito in caso di necessità. In particolare come si procede se non è accessibile il CMS? Grazie. Cordialmente, Mazzoli

You read a lot of advice on how to make a backup with Akeeba Backup, but not rtovo advice on how to restore the site in case of need. In particular, as you progress though it is not the CMS? Thank you. Sincerely, Mazzoli

Sorry to hear you are having problems with your Akeeba restoration. I installed a fresh Joomla 3.4.8 and then the latest Akeeba extension. I was able to create the backup, FTP it down to my local machine, remove the backup from the server, install Kickstart, and FTP and restore the backup file without issue. The default permissions for the jpa file should be 644, however I repeated the process using 777 permissions as well. I do not believe it to be a permissions issue. Unfortunately I am unable to duplicate the issue. I tried with permissions of 000 and the file is still located. Be sure that the file is being uploaded to the root folder for the site as that is definitely what would cause it not to show.

Kindest Regards,
Scott M
Hello Mazzoli, and thank you for your question. If you'd like to restore a backup that you've created for your Joomla website with Akeeba Backup, it's recommended to use the Akeeba Kickstart script to restore this data. For more information regarding this, you can check out Akeeba Kickstart to download the software itself. You can also check out a tutorial video that they've put up regarding restoring using Kickstart which walks you through the process involved. Please let us know if you had any further questions at all. - Jacob