"secure connection failed" on https

  • Answered
My domain name is registered with godaddy and i also bought an ssl certificate with it. I had it hosted their for a while and it worked fine. I bought hosting here, changed nameservers, set up a wordpress blog, but https doesn't connect ("secure connection failed" An error occurred during a connection to votewithcongress.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) ).

Http: works, though. Does this matter?

Thanks for any help.
Hello, Thank you for contacting us about a secure connection failed error. I looked at the domain you have listed (with an SSL checker) and there is no SSL currently installed on this domain. Whenever you migrate a website to a new server, you must also migrate the SSL along with it. If you have all the SSL files along with the CSR, you can submit a ticket to Support requesting installation assistance. After the SSL installation has been completed, you can enable https in WordPress. If you have any further questions, feel free to post them below. Thank you, John-Paul