CMS Page > Edit > Page Content > no pop up window (insert links) work

  • Answered
Hi there,

I am using PrestaShop to edit pages. I go into Preference > CMS > Pages > Edit, under Page Content, I wanted to add links and add pictures. But I click on those buttons, and the pop-up windows don't work.

I had used both Chrome and Firefox, and here's what I got:
Chrome: the pop-up window is a sad face in a grey backback. And console show the following:
GET /js/tiny_mce/plugins/advlink/link.htm:1
Blocked a frame with origin "" from accessing a frame with origin "null". The frame requesting access has a protocol of "http", the frame being accessed has a protocol of "data". Protocols must match.

Firefox: no error message shown in console, but the pop up window says: The connection was reset. The connection to the server was reset while the page was loading.

I had talked to the support person, but using the same username and password, his pop up window works just fine. So I think it's browser issue or something about my computer

Lastly, I have tried to empty cache on Chrome but still did not work


Hello Maria, and thanks for your question.

It is strange that we are not seeing these errors and that you are. Here is a little animated GIF of me trying it out:

I ran across this post about the HTML5 origin specification that seems to be causing this. But I don't know why we aren't triggering the same problem when using Google Chrome Version 29.0.1547.66 m. You can check your version clicking on the 3 striped icon at the top-right of the browser, and then clicking on About Google Chrome.

Aside from a different version of your web-browser I'm not sure what else might be going wrong. There is this post on StackOverflow talking how it could possibly be related to not all resources being on the same domain, but again it wouldn't make sense why this would only be triggering for yourself and not us.

You might want to possibly run a virus or malware scan on your local computer just to ensure that you aren't getting additional content injected into your web-browser or something of that nature. There could also possibly be a extension you're using that's causing the issues. So try starting a Google Chrome Incognito window so that none of your extensions are loaded, or disable them temporarily to see if they are causing issues.

- Jacob