PrestaShop TopHorizontalMenu jQuery issue + Query installation error

  • Answered
I was trying to add/remove items on the top menu in PrestaShop, using Modules -> Top Horizontal Menu. When I configure the Top Horizontal Menu, under Inspect Element -> Console, I have errors saying
"ReferenceError: $ is not defined".
With PrestaShop's online community help, I went to the back-office, and right clicked to "View Page Source", then I could not find jQuery using "CTRL+F".
Then I contacted inMotion's Technical Support, trying to download jQuery. As directed, I went into Perl Module, searched for jQuery, and tried to install jQuery. But the installation failed. I had messages like "ERROR: Can't create '/usr/local/lib/perl5/site_perl/5.8.8'
Do not have write permissions on '/usr/local/lib/perl5/site_perl/5.8.8'
at /usr/local/lib/perl5/site_perl/5.8.8/Module/Build/ line 3602.
./Build install -- NOT OK
You may have to su to root to install the package
(Or you may want to run something like
o conf make_install_make_command 'sudo make'
to raise your permissions.perlmod--Install done"

The technical support tried to help me by giving me permission but same error resulted still.

I had also verified my under config folder has the correct version of jQuery as mentioned here:
So the error is not there either.

Could somebody help me? I really have tried everything I could
Hello mariatao8, and thanks for your question. It seems you might have been getting lead down the wrong road, as jQuery is simply a JavaScript library, and doesn't need to be "installed" on the server. It's simply a collection of .js JavaScript files sitting on the server. I did some poking around and it sounds like one possible fix is to ensure that your file located here:
Has the correct version of jQuery defined, such as:
define('_PS_JQUERY_VERSION_', '1.7.2');
You want to make sure that the version you have defined there, is the same version you're actually using on the server. You can confirm this by looking in the following directory:
You should see a file called jquery-1.7.2.min.js If you instead see a different version there, you can update the to match that version you already have. Or you can download jQuery, in this example the jquery-1.7.2.min.js version would be downloaded from Please let us know if that works out for you. Unfortunately I was unable to pull up your account based off the email address this question was submitted under, so if you'd like us to take a closer look for you please provide the domain name you're having these issues on. - Jacob