Enabling OAuth Extension

  • Answered
Hello. I can't seem to enable OAuth. I have installed HTTP_OAuth using the PEAR package installer. I have tried adding extension=oauth.so to my php.ini. I have changed php versions (currently running 5.4.6). When I run a simple OAuth script, I still get this message: "Fatal error: Class 'OAuth' not found"

Anyone have ideas on how to correct this? Thanks for reading.
Hello MJarratt,

Apologies for the frustration. I checked with our tier2c techs here and they took a look at the issue. One of the things that may have been missing was the option to set the php.ini recursive for the site in .htaccess:

suphp_configpath /home/yourusername/path/to/php.ini

They added this line, but we're not sure what you're running to check on your code. If you could please check this, and then get back to us if it's not working.

If you have any further questions, please contact technical support or leave a comment at the bottom of the page.


Arnel C.