0
Answered

Cannot install module on add on domain (with drupal).

bigapple 9 years ago in Content Management Systems / Drupal 0
I am able to install any module on my main site (drupal 7 site). But on my add on domain, if I install a module by uploading get message:

Unable to create directory 'temporary://update-extraction-eda84aec/ctools/'


If I install a module by "install from a URL", I get message:

* The specified file temporary://fileRdc5AN could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log.
* http://ftp.drupal.org/files/projects/token-7.x-1.0-beta7.tar.gz could not be saved to temporary://update-cache-eda84aec/token-7.x-1.0-beta7.tar.gz.
* Unable to retrieve Drupal project from http://ftp.drupal.org/files/projects/token-7.x-1.0-beta7.tar.gz.
Hi bigapple,

Thanks for your patience. I went ahead and tested it out on my dev server. I found that I got the same error message when I tried to install it using the URL method.

I did however, find what the cause of the problem is:
* You need to go into configuration tab in admin.
* Then, under the media heading click on file structure.
* Once it loads your settings you'l'l need to adjust the Temporary Directory to point to a file folder on your account.
* I create a specific folder called drupal-temp.
* I placed this folder at the same root as I installed drupal.
* You'll have to specify the path to it from the server.

In my case, the path was:
'/home/username/addondomainROOT/durpal-temp'

You'll need to replace username with your actual username.
Then replace the addondomainROOT with your document root for your addon domain.

Once I did that it worked. I hope this helps! If you need further assistance please feel free to contact us!

Thanks!

Tim S
Hi bigapple,

Thanks for posting a question. I'm going ahead and testing this on my dev server. As soon as I have some more information to relay, I'll post a comment here for you.

Thanks for your patience while I look into this for you!

Tim S