Plugin cannot access tmp directory on shared server

  • Answered
I am using a plugin that pulls employee info from our google apps account. The plugin is Google Apps Directory. When I try to search for an employee name I get the error "General Error fetching Google Users: Could not create storage directory: /tmp/GoogleGAL_Client/90". I have been told by Inmotion that the error is because I am on a shared server and someone else on my shared server has already "claimed" that directory.

So how can I get around this? I have tried making a different tmp directory at /home/MYUSER/public_html/ap/tmp/googleapp and then trying to direct PHP to use that directory. I have dones so by trying to add this to the top of my wp-config.php file


That didn't work, so then I tried adding this instead


Still didn't work.

Any idea how to get around this?
Hello Bphilips,

We're sorry to hear that you're having problems with a plugin from Google. We unfortunately cannot correct this issue as it is related to a 3rd party application that we did not develop. You would be better off speaking with the developer of the plugin and seeing if you can specify the determination of the temp folder. They would be able to provide the information that could be part of the changes you're trying to make.

If you have any further questions or comments, please let us know.

Arnel C.