0
Answered

Cannot save or edit product data in Prestashop 1.6.1.4

InMotionFans 4 years ago in Ecommerce / Prestashop 15 0
I cannot save or edit product data in Prestashop. I have tried everything from disableing all modules to disable cache etc... Still no luck I have searched the internet for help still no luck. When I save it just goes back to the original if an edit or a blank field if I am trying to add a new product. Oddly though abought one in ten times it does save.

Please help!
I too faced the same problem, i would recommend to clear smarty cache then
Remove the following lines (252,253,254) :

submitHandler: function(form) {
form.submit();
},

From the file : /adminXXXX/themes/default/template/controllers/products/helpers/form/form.tpl

The issue has been solved at @ https://www.sweetkadai.com
Hello Amel,
partially helped commenting following lines in admin/products.js
/*In order to prevent mod_evasive DOSPageInterval (Default 1s)
if (mod_evasive)
sleep(1000);
*/

Now most of product features can be displayed but prices still not. I have found in console chrome following error

Uncaught ReferenceError: priceDisplayPrecision is not defined
Uncaught ReferenceError: search_product_msg is not defined

Do you know what is wrong?

Best regards
s-piotrek
Hello, Thank you for your contacting us about an issues saving/editing products in PrestaShop. I recommend Enabling Error Reporting in your PrestaShop. This allows you to see the specific error messages on the screen. Also, try with the default Theme if you have installed a 3rd party, or custom-coded Theme. If you have any further questions, feel free to post them below. Thank you, John-Paul