0
Answered

Unable to change Wordpress Address and Site Address in Settings panel

acusfo5 5 years ago in Blogs and Content Management Systems / WordPress 0
My site is hosted by InMotionHosting, the domain name is with a different company and is pointed toward InMotionHosting. The problem is that the links within my site still use the temporary URL (subdomain + inmotionhosting.com). How do I get all my links to use my domain name instead of the inmotionhosting domain and subdomain?

In the Wordpress admin backend (in the Settings > General panel) I'm unable to enter my domain in the "Wordpress Address" or "Site Address" fields (the fields are grayed out and I'm unable to enter anything). I assumed this would be the spot to fix the URL issue. Is there a way to use these fields to enter my domain name?
Hello acusfo5, Thank you for your question on the site address URL being grayed out in your WordPress admin area. This is a recent change that was made within the WordPress back end. If you have set a DEFINE setting within your wp_config.php file for the site addresses, then they will appear grayed out in the Admin area. To fix this, use your cPanel File Manager to edit the wp-config.php file. Simply remove the lines where you set the URL to your Temp URL. There should be two of them. Check near the top of the file as that is the most common place they are inserted. Kindest Regards, Scott M