Which version of PHP does my Joomla 2.5 server run?

Joomla 2.5 has reached its end of life as for 12/31/2014. Please be advised this may be a security risk to your website. You can view more information about the end of life here.

The minimum PHP version number Joomla 2.5 needs to run is PHP 5.2.4. You may want to install certain Joomla 2.5 extensions however that require a higher version of PHP. In those cases, you’ll need to know which version of PHP your hosting server is running. In this Joomla 2.5 tutorial, we’ll walk you through the steps for finding out which version of PHP your Joomla 2.5 server is running.

To find out which version of PHP your Joomla 2.5 hosting server is running:

  1. Log into your Joomla 2.5 admin screen
  2. In the top menu, hover over Site and click System Information
  3. if you’re not on the System Information tab, click the System Information tab. On this page you’ll see a setting labeled at PHP Version:
    joomla-25-php-version

    As you can see from the screenshot above, our Joomla 2.5 server is currently running:
    PHP Version 5.2.17

2 Comments

Was this article helpful? Let us know!