353: Editing the slideshow on the main page in PrestaShop 1.5

When working with your PrestaShop store, you may want to edit or add to the images that appear on the slideshow on the main page. This article will guide you on how to alter the slideshow on your main page in PrestShop.

Editing the image slideshow on your main page

  1. Log into your PrestaShop admin dashboard.
  2. click on modules option

    Using the upper toolbar menu, hover over the Modules tab and click on the Modules option.

  3. find module in list

    From the Modules page, locate the Image slider for your homepage module. Click the Configure link.

  4. the configuration screen for the module

    This brings you to the module configuration page. There are two sections here to allow you to customize the slider.

    Slider Configuration

    Height The pixel height of the slider window.
    Width The pixel width of the slider window.
    Speed The speed, in milliseconds, of the image swap.
    Pause The time, in milliseconds, of the pause between image swaps.
    Loop Toggle whether you want the series to loop or not.

    The second area, Slides configuration is where you can add, edit, enable/disable, or delete a slide from the slideshow list.

  5. Once you have configured the settings for the slider to your liking, click on the Save button found under the Slider Configuration section. Any changes to the Slides Configuration section are automatically activated and do not need to be saved.

Thoughts on “353: Editing the slideshow on the main page in PrestaShop 1.5

    • Hello,

      Apologies for the problem with the option not removing the navigation arrows with one slide. You would need to speak with PrestaShop or obtain add-on that could show your slide without the navigation arrows. Since this is a modification of the PrestaShop software, you will need to ask them how it can be done.

      If you have any further questions, please let us know.

      Kindest regards,
      Arnel C.

    • Hello Galeowz,

      I spent some time looking for a way to change the behavior of the slide direction, but I couldn’t find any find information on it. The best way to get information on this will be to contact PrestaShop support. Otherwise, you may need to purchase a custome slidehow module that will work the way you want it, or have a developer create one for your needs. Apologies that I couldn’t provide you a direct answer! If you have any further questions or comments, please let us know.

      Regards,
      Arnel C.

  • After updating Prestashop to the latest version, my image slider is no longer centralised. It sticks to the left. How do I fix this problem?

    • Hello HH,

      Try adjusting the layout by going to Modules >> Positions. From there you can adjust the location of different items on the front page such as the slider. That may help you.

      Kindest Regards,
      Scott M

  • Dear Scott,

     Thank you for your information. I will try what you have said see if it works. the slider still didn’t work. Why you see it work correctly is because I installed a slider module  and that module works. but I cannot change the speed of the slide and the orgignal picture is still at the bottom of this slider module. so when the picture move customer will be able to see the non-move picture at the bottom.

    Thanks!

    Jenny

  • Dear Scott,

      the version is 1.6.0.9-1.919s. I did upgrade with the theme once. i didn’t use any module for the slider show. I thought this function come with default.  by default it has a homepage slider module. Do I need to install other modules?

    http://addons.prestashop.com/en/demo/FO9798.html (this is what I have now)

    I really need this funtion. Please help me on how to make it run automatically. Thank you so much!

    Sincerely,

    Jenny

    • Hello Jenny,

      Thank you for the additional information. I did have this issue once when upgrading, but have not had it for some time, so I am trying to remember how it was corrected. Check with the module and ensure it is up to date. Once updated, if that did not fix it, disable and then re-enable the module. Another thing you may want to try for the sake of testing is to revert back to the default theme and see if it works then. If it does, then the theme is likely interfering and that is something the theme developer would need to change. Hopefully the things I gave you above will correct it.

      Kindest Regards,
      Scott M

    • Currently, I see your slider operating without any issues on the site you have provided. Were you able to resolve the issue?

  • Hi.

    I bought a theme called Ascetic 1.6 version 1.6.0.9. I also have the problem about the homeslider. it won’t run automatically, was it because of the version? or what configuration I can do to make it run automatically?

    my webpage is http://mall.mypeople.tw

    Thank you very much.

    we are about to launch the on line store, so I really need an answer!!

     

    Sincerely,

    Jenny 

    • Hello Mary,

      What module are you using? PrestaShop typically has a small trashcan icon as a delete button. Do you not see that? What version of the module are you ising? What specific version of PrestaShop are you using?

      Kindest Regards,
      Scott M

    • Hello Jenny,

      What specific version of PrestaShop are you using? Was it an upgrade or was it a direct install? Also, have you checked to see if the module needs an upgrade? What specific module are you working with?

      Kindest Regards,
      Scott M

  • Good morning,

     

    Please, i have a gallery with pictures not on the home page, i cant see how to add images but i cannot seem to delete,

    what do i do?

    Thank you

     

  • Hi, this is a great module…just one little thing would it be possible to add the choice
    to open the link in a new window ? sometimes you want to refer to an external site
    and now it onpen every link in same window and gives an error if you dont put any
    link (cause it is possible to put it as a link in the html box).

    • Hello Guylaine,

      The module does not feature a setting to set the link to open in another window. If you have coding experience and want to venture into the module core code I’m sure it could be altered to do that.

      Kindest Regards,
      Scott M

  • Hello John-Paul,

    Than you for your reply. 

    I use WD Content Slider v1.1.0.  I think I do not have any other Addons/plugins.

    Thank you for your help.

    Lenka

    • Hello Lenka,

      Thank you for contacting us today. I could not find a helpful guide on how to change an image in the WD Content Slider.

      We are happy to help, but will need some additional information. Can you provide a link to the site you got the slider from.

      Was it included with your Theme? What theme was it?

      Can you provide a link to your website?

      If the WD Content Slider is giving you too much trouble, I recommend just following the guide above to add a slider to your PrestaShop site.

      Thank you,
      John-Paul

    • I want to know how to add more images in the slider in homepage. Currently there are only three images. I want to add more. So this article is not what I am looking for. Thank you

  • Hello,

    I would like to ask someone who could help me. I’ve deleted a few slides from the Module Content slider and now, on my website, there appear blank pages (white picture) instead of the advertisement I want to have there.

    I am very thanful for any sort of help.

    Lenka

    • Hello Lenka,

      Thank you for your question. We are happy to help, but need a little more information.

      What Slider module are you using for PrestaShop?

      Are you using any other Addons/plugins?

      If you have any further questions, feel free to post them below.

      Thank you,
      John-Paul

  • hello maybe you can help me,

    my page is set to English only but i can’t find here to get rid of this French writing on the home page. Maybe someone can help me out.. also i have another issue, how do i activate the website so customers can view the site on the internet? it is complete and needs to go up, but don’t kno here to find how to do that- ell it ill be ready once i get rid of this French writing.

     

    thank you

  • Hi,

    I am writting here because I have spent hours trying to remouve the text on my sliders (home page leo fashion theme on prestashop 1.5) “MAGASINER MAINTENANT” This text is like a small box in the middle on all my banners. There is no way to remouve it from the back office. If someone know plz help.

    Thank you 

    • Hello Fati,

      Sorry that you’re having a problem with the slider. The theme you are using is a third-party theme from Theme Forest, so it is unfortunately a theme for which I have no access. I can tell you that in the default theme there is a block module called “Image Slider for the Homepage” – when i look at this module, I see the slider contents and the text (if you edit each individual picture). This is true in BOTH 1.5 and 1.6. The text (which is “shop now” in English) shows up on each slide in the 1.6 version. Since this is a paid theme from Theme Forest, you may need to contact their support if you continue to have the problem. We would need to have access to the theme in order to look at it.

      Kindest Regards,
      Arnel C.

  • Hi there,

    Trying to change my website TM Banner Block and Touch Slider content (the Image) but it keeps showing the old image that I had.

    Tried to add in the new ones and deleted the old one but it shown the old one again after clicking on the “Save” btn.

    Any idea how can I get it changed? Thanks!

    • Unfortunately, I have searched to find the PrestaShop module that you are referring to and I have been unable to locate information about it, outside of just a few people having issues with it in PrestaShop 1.4. I recommend getting in contact with the plugin developer that you received it from the investigate any issues that may exist within it.

      It is also possible that this could just be a caching issue in which clearing your browser cache could possibly resolve the issue.

    • Hello Patrick,

      The theme that you’ve selected, yes, it does require the older version of PrestaShop 1.5. PrestaShop 1.6 is the latest stable release, and is what I would recommend if you are just starting out building a store.

      I would recommend looking for a theme that actually works with that version rather than trying to get something that wasn’t built for it to work.

      – Jacob

  • so,i have to use the version 1.5 or………….?i tried to open the link in your last message but nothing,so the 1.5 is the stable version?

    thanks

  • i am realy confuse,i just tried right now with another browser mozilla firefox,its the same thing unfortunately.

    can we get a live chat?on skype or somewhere else,i dont understand what is the probleme with prestashop

     

    • Hello Patrick,

      I see now that it’s broken. However when you first posted the link it was working. It looks like you’re using PrestaShop 1.6. I apologize as you were commenting on this article of ours specifically related to PrestaShop 1.5 I had assumed that’s what you were using.

      The Simple Black theme is not compatible with PrestaShop 1.6. You can see this by going to the Simple Black PrestaShop Theme page, and then click on the Data sheet tab, notice how it says Built for PrestaShop version: 1.5.6.1-2 this is a good indication that it probably won’t work with the 1.6 version.

      In cases like this when the default theme is working, and one you download is not, chances are the one you’ve downloaded has problems.

      – Jacob

    • Hello again Patrick,

      When I go to that URL you’ve provided, I am able to see the image slider working as expected. Are you still having any issues with that public site from your end?

      If you are still having problems seeing the image slider correctly, what web-browser are you using? Could you possibly try another web-browser on your computer to see if it’s also having the same issue?

      – Jacob

  • thanks for your answer mr Jacob,i am uploading a a free server right now,so i would like you to see the result please.

    thanks!

  • ok,please can we go back

    1-how can i install a new theme in the new prestashop

     

    2-the theme that i installed before has the images of the default theme,why?

    thanks

    • Hello again Patrick,

      We have a guide that covers how to install a theme in PrestaShop 1.5 as well as how to install a theme in PrestaShop 1.6 depending on the version you’re using. Basically you’d want to extract the PrestaSkins_Theme_Simple_Black.zip file that you downloaded locally first.

      Then inside that extracted folder, navigate to the /themes directory. You’d want to move the PS_Simple_Black folder to your PrestaShop’s /themes directory. That directory should then look similar to this when viewing it:

      debug.tpl
      default/
      index.php
      live_edit.tpl
      PS_Simple_Black/

      Then you would Login to PrestaShop, hover over Preferences and click on Themes. You should then see the PS_Simple_Black theme towards the middle of the page. You’d want to select the radio button under it, then click on Save to activate the theme.

      I’m not sure what you mean by your second question. When you first setup the Image slider for your homepage module in PrestaShop it comes with some default images already so that’s what you should be seeing by default.

      – Jacob

  • i will look for a free server but maybe the problem is that i didnt install well the new theme.

    when its on a server i will let you know,thanks

     

    • Hello Patrick,

      No problem at all, hopefully it was just a missed step in unzipping the theme files and you can get it to work locally as well. Either way, let us know if you figure it out!

      – Jacob

    • Hello again Patrick,

      If the default theme works, then I would have to assume something is missing from your Simple Black theme. Do you actually see the theme change the look of your store when you have it active, does everything look proper other than the image slider?

      I noticed when I downloaded the .zip file for the theme, there were 2 other .zip files contained within it. The theme files themselves are located in the PrestaSkins_Theme_Simple_Black.zip file and need to be placed in your /themes/PS_Simple_Black directory.

      Here you can see below I’ve got the theme loaded on one of our servers and it’s working without any issues:

      Without being able to see your full local site it would be hard for us to troubleshoot this problem for you. Do you happen to have the ability to load your site on a public accessible server where we could take a look?

      – Jacob

  • thanks very much for your quick response

    i am working localy,i am using a beta template or a free template,i am working on it to understand how works prestashop,so i installed the new template the name is simple black from prestaskins.com,i changed of images on the image slider on the index page,but images appear in column,from the top of the page to the bottom and no animation of course

    please,help me

    thanks

    • Hello Patrick,

      Unfortunately it will be a bit tough to troubleshoot what might be wrong if your installation of PrestaShop is local. My guess would be that you either don’t have the required jQuery JavaScript, or CSS files stored locally, or that the files in /modules/homeslider are having issues.

      I went ahead and downloaded the Simple Black theme and was able to load it in PrestaShop and still have the image slider work. Did it work at all before you added any custom images to it?

      – Jacob

    • Hello Didier,

      Sorry to hear about the problems with your images. Unfortunately, you have given us very little to work with in order to troubleshoot your problem. If you can provide information on your settings, your images, or at least provide a URL, then we can look into the issue for you. There are many possibilities that my cause the slider not to work, but we need more information in order to determine the source of the problem.

      Please provide more information and we would be happy to help.

      Regards,
      Arnel C.

  • In Prestashop 1.6.x, is there a way to add more images in image slider, then default 3 images? (under module “Image slider for your homepage”)

    Any help appericiated.

     – Regards, Sam

  • The image slider has french text ontop of it (actually on the slider itself – not in the homepage) that cannot be edited or removed with the home editor. I have spent 6 hours trying to figure this one out. It is definitely NOT embedded into the photo as its highlightable with the text-drag feature of the mouse

    “EXCEPTEUR
    OCCAECAT Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin tristique in tortor et dignissim. Quisque non tempor leo. Maecenas egestas sem eli”

     

    is on the fashion default theme but I cant remove it from the header block because it is actually printed over the slider. NO THE HOME EDITOR DOESNT DO ANYTHING… Please help

    • Hello Lance,

      Is your PrestaShop language set to French? That text is temporary template text, and it seems like some PrestaShop users have reported this text goes away when switching to another language like Vietnamese, so I wonder if it’s tied in with a language template.

      If you’d like for us to take a look we would need the domain you’re having these issues on. If you’d like to just reply to this comment with that info, we can delete any private data before making the comment go public.

      – Jacob

    • Hello Allan,

      As this article is for PrestaShop 1.5, it will not necessarily have the correct instructions for 1.6. We are currently working on creating articles for 1.6 and I will definitely check into the behavior of the slider for the new version.

      Kindest Regards,
      Scott M

  • Under my slide Image, I have only one slide configuration setting, not the second part slide configuration, whereby I can add new slides, any idea?

    • Hello Janice,

      Both configuration settings should be there by default. I would try Uninstalling the module and then reinstalling it to see if there was a glitch. Also, what specific version of PrestaShop are you using? Did you make any other changes (modules added, etc)?

      Kindest Regards,
      Scott M

Leave a Reply