308: Installing vQmod on OpenCart 1.5

vQmod is an override system designed to avoid having to change the core files of OpenCart. Instead of making changes to the core files of OpenCart directly, the changes you make are created as XML search and replace script files. vQmod has no effect on the performance of OpenCart as noted by the developers. There are quite a few modules and scripts available to use with vQmod, and you’ll need to have vQmod installed for them to work properly.

  1. Download the latest version that has “OpenCart” in the title from: vQmod Installation
  2. Using FTP, upload the “vqmod” folder from the zip to the root of your opencart store
  3. Be sure the vqmod folder and the vqmod/vqcache folders are writable (755)
  4. Go to http://www.yoursite.com/vqmod/install
  5. You should get a success message. If not, check permissions above and try again
  6. Load your store homepage and verify it works
  7. Using FTP, verify that there are new “vq” files in the “vqmod/vqcache” folder

If you need further assistance please feel free to ask a question on our support center website.

Thoughts on “308: Installing vQmod on OpenCart 1.5

  • I have installed Extension – Option Image Swap but when I go product edit from Admin it gives me error

     

    Fatal error: Call to undefined method ModelCatalogProduct::getSwapOptions() in /vqmod/vqcache/vq2-admin_controller_catalog_product.php on line 1126

    • Hello Jigar,

      You will need to check with the developers of the extension in order to determine the reason and resolution for the error.

      If you have any further questions or comments, please let us know.

      Regards,
      Arnel C.

  • Hello Arik, First of all thanks to give us free module of imort,export and installation help.

     

    i have use opencart 2.0.1.0 version. i have already install 2.0.1.0 vqmod and also give user permision. but 

    module not display on admin panel in system option. will u give some help? why module not display? please help me to solve problem thanks in advance

     

     

    • Hello Kapil Vyas,

      Sorry for the problem with the extension. However, we need more information on the “module” you’ve attempted to use. Can you please provide the exact name and version? Provide further information that so that we can accurately investigate the issue you’re reporting.

      Kindest regards,
      Arnel C.

  • Dropped it into my FTP, tried the URL www.(sitename).com/vqmod/install

    Just says I do not have permission. All permissions are allowed on the vqmod folder… any help? thanks

    • I’ve successfully installed vqmod for OpenCart 2.0
      I put the website on a sub directory: public_html/anu
      To install the extension, I have to set up my FTP root under admin panel.
      But I am confused with the FTP root. Can you help me to know the FTP root is?
      Thank you before, from beginer
      Arik

    • Hello Arik,

      The main FTP account is the one where you use your cPanel username. The FTP root for that is your home directory, or ‘home/userna5’, for example. You can also create FTP accounts and assign them different FTP root directories as needed.

      Kindest Regards,
      Scott M

  • Hi John-Paul,

    I’ve installled VQmod for OpenCart 2. Unfortunately the mods I own and wanted to use have not been re-written for OC2 yet.

    Thanks for your response. It’s all sorted now.

    Cheers,

    Kelly

     

     

  • So…. I followed your insructions and then I read that this was not for version OC2. How do I uninstall the incorrect 1.5.x VQMOD version from my system? If I just delete the vqmod folder it throws errors and I can’t access the cart.

    • Hello Kelly,

      Thank you for your question. There is a 3rd party extension called VQmod for OpenCart 2 that can help you manage the versions.

      We are happy to help further, but will need some additional information, such as the full error messages.

      Thank you,
      John-Paul

  • at first i thank you for all previous assistence. I have now 2 problem-

    1) I followed all of your steps to install vqmode in OC 2.0 . but it says 404!

    We couldn’t find that page…..

    2)I dont know how to activate both sidebar of my website. tried in modules option or layout option i select right side to show all of my categories but no positive output. Such as I like to add poster in right sidebar also silde show in left. Really in trouble. this is my website- http://www.muslimbd.com.

    Could you take a look for me? Hapy to provide admin login.

     

    Thanks

    Dr sharear Azam

     

    • Hello Dr. Sharear Azam,

      Sorry for the problems with the installation. The main issue is that these instructions are NOT for Open Cart 2.0. They were created for OpenCart 1.5x vqMod versions. Please follow these directions for now ( I will be publishing new directions for the installation of vqMod 2.x in the near future).

      1. Download the latest version of vqMod for OpenCart 2.0 here.
      2. Upload the files into your OpenCart’s MAIN DIRECTORY (where ever you installed your OpenCart files on the server). Note that the following files will be overwritten by the vqMod upload: admin/controller/extension/installer.php, admin/controller/extension/modification.php.

      It’s fairly quick, but note the difference from 1.5 in that the files are being uploaded into an EXTENSION sub-directory.

      Apologies again for the confusion. Hopefully, these directions will help with the installation. I got them directly from the README file in the ZIP file for the extension installation. Once I have verified and obtained screenshots, I will publish the directions for the new version.

      Kindest regards,
      Arnel C.

  •  

    404!

    We couldn’t find that page.

    Please check to make sure you’ve typed the URL correctly.

    This webserver is CaSe SenSiTiVe so ensure capital letters in the URL match the files uploaded.

  • I keep getting this error.  Any information would help thanks. 

     

    Notice: Undefined index: smp_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line20Notice: Undefined index: smp_h1_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 21Notice: Undefined index: smp_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 20Notice: Undefined index: smp_h1_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.phpon line 21Notice: Undefined index: smp_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.phpon line 20Notice: Undefined index: smp_h1_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 21Notice: Undefined index: smp_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 20Notice: Undefined index: smp_h1_title in/hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 21Notice: Undefined index: smp_title in/hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 20Notice: Undefined index: smp_h1_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 21Notice: Undefined index: smp_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 20Notice: Undefined index: smp_h1_title in /hermes/bosoraweb106/b1624/dom.randwoutfitterscom/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 21

    • Hello,

      We do not get this error when installing VQMod on our OpenCart test environment. What version are you using for both the OpenCart and the VQmod? Are you doing anything other than specifically following the instructions above? Do you have any other third party extensions installed? If so, which ones?

      Kindest Regards,
      Scott M

  • Fatal error: Call to a member function isLogged() on a non-object in /home/medihome/public_html/catalog/model/catalog/product.php on line 8 can anyone assist me

    • Hello Keshava,

      Sorry to hear that you’re having problem with the Vqmod. If you moved your site, then it may have to do with the issue as noted in this forum post:

      OpenCart Forum

      Check and see if their solution will fix your issue. If you continue to have the problem, please provide some details on the account and we can investigate it further.

      Regards,
      Arnel C.

    • Hello Aaron,

      Are you having trouble with a specific step from the instructions above? If so, please let us know so we can assist you.

      Kindest Regards,
      Scott M

  • Hi

    I have installed the extension and the latest version of vqmod, ticked all permissions in the user group but still not seeing it in system.

    Could you take a look for me? Hapy to provide admin login.

     

    Thanks

    Taryn

     

    • Hello Taryn,

      Did you get the success message with the install? Are you able to see files in the ‘vqmod/vqcache’ folder? If so, then all is well. If not, please reply with any error messages you received when performing the install so we can assist that way. Of course, logging in and checking can be done, but since this is a public forum, we advise against placing that type of information here. If you are a customer for InMotion, you may contact our Support department and have them check the files for you.

      Kindest Regards,
      Scott M

Leave a Reply