|Issue:||WordPress has released an update (4.1.2). This is a critical update|
|Status:||Update has been released.|
|Who is impacted?||Websites running anything less than 4.1.2.|
Why was this update released?
WordPress versions 4.1.1 and earlier are affected by a critical cross-site scripting vulnerability, which could enable anonymous users to compromise a site. This was reported by Cedric Van Bockhaven and fixed by Gary Pendergast, Mike Adams, and Andrew Nacin of the WordPress security team. Also fixed are three other security issues:
- In WordPress 4.1 and higher, files with invalid or unsafe names could be uploaded. Discovered by Michael Kapfer and Sebastian Kraemer of HSASec.
- In WordPress 3.9 and higher, a very limited cross-site scripting vulnerability could be used as part of a social engineering attack. Discovered by Jakub Zoczek.
- Some plugins were vulnerable to an SQL injection vulnerability. Discovered by Ben Bidner of the WordPress security team.
You can read the official announcement at the WordPress.org site.
What should I do?
WordPress strongly encourages you to update your sites immediately.