My website is showing 'your connection is not private', how do i rectify it?

  • updated
  • Answered
Arnel C

Hello Doniervask,

The answer remains the same.  In order for you website connection to be considered "private" you will need to have an SSL certificate.  We provide free SSL option as noted by Stormy below.  You can also purchase an SSL through a third-party.  Please reference our article on how to install SSLs for more information.

If you have any further questions or comments, please let us know.

Kindest Regards,

Arnel C.


It’s a message from your browser that informs you that the connection is not secure. The most common cause of “Your connection is not private” is an incorrect date & time set on your PC. Chrome makes sure that your computer’s clock matches the clock in a Google server farm, and if it doesn’t, will block the connection to HTTPS sites for security reasons.

To fix your issue, set your computer’s clock to the correct current time.

  • Go to System Preferences
  • Choose Date & Time
  • Navigate to the Date & Time tab
  • Change the current time to the correct time (accurate to the nearest minute will do).

If it’s not your computer’s fault, it’s just a Chrome security feature. Chrome detects malicious activity going on with the site (like malware-laced ads, breach by hackers, etc.) and automatically warns you to protect you if it believes your security or safety might be at risk. If you want to override the warning, just hit Advanced -> Continue to site.

  • Answered

Hi Ekelaka, 

Thank you so much for your question! To secure your website, you will need to enable your free SSL. If you have additional questions, please reach out to our live 24/7 support

Kindest regards,