Answer

Answer
Answered

Hi Michael! I looked this up in Apple documentation/forums and it seems to be a common problem after recent updates. 

As a preliminary, please make sure you are using IMAP as POP3 does not have push as an option.

First, please try going to:
Settings > Password & Accounts > Fetch New Data > iCloud

This is just to be sure that Push is selected as an option.

If that does not present Push as an option, for the time being I would suggest using Fetch at what seems like an appropriate interval and following up in Apple specific support, though based on what I'm reading it may not be resolved until the next update. We aren't Apple specialists, though, so I would encourage you to check their support as well. I hope that helps though!

Answer
Answered

Hi Michael! I looked this up in Apple documentation/forums and it seems to be a common problem after recent updates. 

As a preliminary, please make sure you are using IMAP as POP3 does not have push as an option.

First, please try going to:
Settings > Password & Accounts > Fetch New Data > iCloud

This is just to be sure that Push is selected as an option.

If that does not present Push as an option, for the time being I would suggest using Fetch at what seems like an appropriate interval and following up in Apple specific support, though based on what I'm reading it may not be resolved until the next update. We aren't Apple specialists, though, so I would encourage you to check their support as well. I hope that helps though!