PHP Edit crashed website

  • updated
  • Answered

I edited my PHP settings to increase max_execution_time from 30 secs to 180 secs. Now my enter site has gone down with the error 'There has been a critical error on this website.'

How do i fix this?

Arnel C
  • Answered


Sorry for the issue with your crashed website after increasing the max_execution_time.  Without seeing your site, it's hard to identify the issue.  However, if you go back and set back the execution time back to 30 seconds, your site might not crash.  Generally, when you're getting an error after increasing execution time, it may be related to the allocated memory.  Try increasing the memory settings for PHP and see if it makes a difference.  

If you are increasing your settings to help with performance, then increment them gradually.  Check your error logs as you change your settings. If you require additional assistance, I recommend that you either contact our live technical support team (if you are an InMotion Hosting customer) or speak with an experienced developer.

If you have any further questions or comments, please let us know.

Kindest Regards,

Arnel C.