Email Filters - Pipe to a Program

Avatar
  • updated
  • Answered

I have created an email filter, selecting the action 'Pipe to a Program'. It seems that no matter where I place the PHP script, I get a bounced back email with an error message like the following:

pipe to |/home/[username]/scripts/emailpipe.php
generated by [[email protected]]
local delivery failed

The following text was generated during the delivery attempt:

------ pipe to |/home/[username]/scripts/emailpipe.php
generated by [mye[email protected]] ------

cagefs_enter: /home/[username]/scripts/emailpipe.php: No such file or directory

According to cPanel documentation, the path to the script entered here should be relative to the Home directory. So, 'scripts/emailpipe.php' should work. It does not. I have tried moving this script around to several different directories and still, it cannot be found by the Email Filter process. The above error message example is from the attempt when I tried entering the full path to the file.


*Note that the permissions on this PHP file are correct. This is not a question about permissions. I have tried having them set at 0700 and at 0755 and other variations. This does not affect the problem I am having. It appears that the script itself is not being found.

What is this path supposed to look like in order for the script to be found by the filter?
A specific example would be helpful.

Thank you

Avatar
Chris M
  • Answered

It looks as though your initial troubleshooting was correct, those are all steps I would have suggested.  If there is something in the server environment that could be blocking execution of the script the best course of action i could suggest would be contact live support so they can troubleshoot the issue inside your account.