Analytics API service error 403: Error calling GET

  • Answered
I get this error on my wordpress site:

There was an Analytics API service error 403: Error calling GET (403) This service is not available from your country

I am using the Google Analyticator plugin to display google analytics on the dashboard and the above error appears on the dashboard where the analytics used to be. This error just started appearing yesterday. The plugin worked fine before this. This same error also appears in another one of my InMotion sites where I am using a different plugin called Google Analytics Dashboard for WP (does the same thing as above plugin). Google appears to think that my sites are hosted from a google banned country but I believe all inmotion servers are in the US.

I posted on the Google Analytics Dashboard for WP support forum and found many people who used InMotion are having the same issue. I'm not sure if it happens with other hosting companies. Please advise.

Same here ( Wordpress and all plugins upgraded to their latest version, tried with three different Google Analytics plugin (Yoast, Better,...) - all are saying "country blocked".

Please could you fix the IP with Google?

The folks at InMotion moved me to another server, and the issue was resolved. But as Mr. TJEdens stated, it does seem to be a problem that stems from Google. Send an email to InMotion support and if they migrate you to a new server, give it about 24 hours before the changes take effect. And be sure to clear your cache before trying the plugin again.
Hello wpdan, Thank you for contacting us about an "Analytics API service error 403" and "This service is not available from your country" error displaying with the Google Analyticator plugin. I immediately noticed the current version of the Google Analyticator plugin is not officially compatible with the latest version of WordPress: Requires: 3.2 or higher Compatible up to: 4.2.5 There was also the same unanswered question on the developer's support forum. We are happy to help you test this further but need some additional information. What version of WordPress are you runnning? What version of the plugin are you using? Please include any information that will help us test and replicate this error. Let us know if you have any further questions. Thank you, John-Paul