Broken cPanel Link in AMP

  • Answered
I am attempting to create an email address for my domain but when I click on "Add an Email" from within AMP...I get a dead link that says "Redirecting" and then times out. I get the same error when I click on the cPanel link directly from within AMP. I made sure that I was properly logged into AMP on each occasion that I attempted to connect to cPanel...I even tried the method with no luck.
Hello jonesjer, and sorry for the issues. It sounds like you could possibly be having an issue with the ports that cPanel uses if you're behind a firewall. You can bypass your firewall with cPanel proxy subdomains to see if that lets you get in. Just try: If you are still having issues, it's not as likely, but you might be having problems with the cPanel security tokens as well. If neither of these does the trick for you, please let us know what web-browser you are using. I just tested my own account in Google Chrome and Mozilla FireFox and I'm not able to recreate these problems at this time. - Jacob