sql permissions error

  • Answered

I am trying to get an output from my sql database and seem to be getting a permissions error.
the command i'm using is:
SELECT * INTO OUTFILE 'backup.txt' FROM user_insts;

and the error is:
#1045 - Access denied for user 'voidsn5'@'localhost' (using password: YES)

I can run select, insert,update and delete query's perfectly fine. just not when i need to get an output to file.

I have tried fully qualifying the file name but still no joy.

Any help would be greatly appreciated.

Tim S.
Hi deaneevans,

Thanks for posting your question. I'm more than happy to assist you. The "FILE" privilege is not available in shared hosting due to security concerns. To use the command in the way it is written, you'd need to be on a VPS or dedicated server.

I've tested this out on my shared testing account to be sure. I get the same error as you produced even when the MySQL user has all privileges assigned.

If you need further assistance please feel free to contact us.


Tim S