CAN not checkout on drupal

  • Answered
I ve got the same problem but it appear after clicking on checkout button in the shopping cart it takes a lot of time at the end it gives the error i ried to change the my.cnf as root addig and changing all the values especialy that advised by all: max_allowed_packet = 32M I ve tested most of the numbers thinking that will do I ve set it even to :500M But nothing changed Everythiing on navigating the site is ok no errors but on clicking the checkout it searches at least
Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 2006 MySQL server has gone away' in /home/username/public_html/includes/database/ Stack trace: #0 /home/username/public_html/includes/database/ PDOStatement->execute(Array) #1 /home/username/public_html/includes/database/ DatabaseStatementBase->execute(Array, Array) #2 /home/username/public_html/includes/database/ DatabaseConnection->query('SELECT expire, ...', Array, Array) #3 /home/username/public_html/includes/ db_query('SELECT expire, ...', Array) #4 /home/username/public_html/includes/ lock_may_be_available('theme_registry:...') #5 /home/username/public_html/includes/ lock_acquire('theme_registry:...') #6 /home/username/public_html/includes/ ThemeRegistry->set(Array) #7 [internal function]: DrupalCacheArray->__destruct() #8 {main} thrown in /home/username/public_html/includes/database/ on line 2204 I've tried all solutions but the same problem [2nd post info] I ve tried to change the /etc/my.cnf at least for the problem of max_allowed_packet | 134217728 I changed it to be max_allowed_packet = 128M But when I check up mysql variables it is still :max_allowed_packet | 134217728 and there is no effect of the change it does not exist So has anyone a problem the like thanks a lot
Hello Mhamed, Sorry for the problem with checking out of your Drupal site. I looked around for this and your best bet is to consult with the Drupal support community. The settings that I see suggested to resolve this issue do not match what you have provided above. Please see this post and try the settings that they are suggesting to fix the problem. The innodb settings may the ones you need to implement to resolve the issue. NOTE: I removed your second post and put your information on this initial post as the answer I have is the same. If these settings do not help, then consulting with the Drupal Support Community will be your best course of action to resolve the issue. You may also submit a verified support ticket to have our systems team review the database if the innodb settings did not help. They are able to restart the server or review any query issue. I hope this helps to fix your problem, please let us know if you require any further assistance. Regards, Arnel C.