Cannot save product variables in woocommerce

  • Answered
When I am adding products in woocommerce that have lots of variables ( 50+ ) anything over about 40 does not get saved. After doing much research, I believe I have tracked this down to a problem with the server not allowing any posts with over 1000 field values to be saved. To confirm this I have installed a plugin called 'WP Max Submit Protect" which tells you if you are going over the max in a post allowed by the server, which according to it I am.

Currently the product I am working on has roughly 1300 and it warns me that the max allowed by the server is 1000. In my research I was advised to edit the php.ini file with the following code "max_input_vars = 2000" and if that didn't work, to add "php_value max_input_vars 2000" to my .htaccess
Adding the code to php.ini does nothing and adding the code to my .htaccess results in a 500 error when trying to view the website.
Inmotionhosting support has tried putting a link in .htaccess to php.ini and making it recursive which has also yielded no results.

How can I fix this and set the max allowed fields to say 2000 so I can save my data and finish this website?
Scott
Hello, Sorry to hear about your issues with the max_input_vars not working correctly. If the php.ini is set properly and the .htaccess is recursive, then the max_input_vars should work properly. The best way to check is to create a temporary phpinfo page and then visit that page to view the max_input_vars setting. You will want to have the phpinfo test file at least one folder down from the root folder so it will also demonstrate the recursiveness. I see from the notes that the issue was resolved by rewriting the recursive line in the .htaccess. Please let us know if you have any other issues. Kindest Regards, Scott M