SEO Friendly URLS and Opencart 2.0+

  • updated
  • Answered
We have recently purchased a hosting package with you with a view to running the latest version of Opencart, which Is now 2.0+
We are looking to enable the SEO feature in Opencart but don't seem to be able to get it working correctly. I have enabled SEO Urls in the Opencart system settings panel. I have given products and categories SEO friendly urls using - instead of spaces. I have changed the htaccess.txt to .htaccess
The Opencart store is installed in the /public_html/ folder.

What I am finding is the SEO friendly URLs look like they are working for categories and the products are listed within the categories but when I click on a product I get presented with the message from Opencart saying "The page you requested cannot be found!".

Any help would be great! :)
Arnel C

Hello Connecticut,

Sorry for the issues with OpenCart.  We have no information from you on the issues that you might be facing.  We can only assume they are similar to this post from several years ago.   If you look at the response, ensure that the URLs are working without SEO-friendly URLs first.  Also, check to make sure that you have cleared your browser cache.  If a problem is still occurring, please describe the issue in detail so that we can look into it further.

If you have any further questions or comments, please let us know.

Kindest Regards,

Arnel C.


Hello olly,

Thank you for contacting us about issues using SEO friendly URL's in OpenCart.

We are happy to help troubleshoot further, but will need some additional information. Did you verify the Products are loading with SEO friendly URLs disabled?

Have you tried clearing your browser cache before testing? I have seen this work in the past.

Since extensions/addons can modify your .htaccess file, have you tried disabling any 3rd party extensions?

If you have any further questions, feel free to post them below.

Thank you,

John-Paul B