0
Answered

Cannot install Apache::GeoIP (1.99) in cPanel

ejbang 7 years ago in Our Software and Tools / Cpanel 0
I have trouble in installing Apache::GeoIP (1.99) perl module in cPanel.
Here are steps to reproduce the problem.
1. I log in AMP.
2. I link to cPanel.
3. I link to Perl Module Installer.
4. I click [Show Available Perl Module(s).
5. I browse Apache::GeoIP (1.99) perl module and click [Install] button of Apache::GeoIP (1.99).

then it is not installed saying as below:
...
CPAN: File::Temp loaded ok (v0.22)
CPAN: Parse::CPAN::Meta loaded ok (v1.4401)
CPAN: CPAN::Meta loaded ok (v2.112621)

CPAN.pm: Building R/RK/RKOBES/Apache-GeoIP-1.99.tar.gz

perl-64bit-hack: enabled
Please install either mod_perl 1 or mod_perl 2 first at Makefile.PL line 118.
No 'Makefile' createdCPAN: YAML loaded ok (v0.77)
RKOBES/Apache-GeoIP-1.99.tar.gz
/usr/local/cpanel/scripts/cpan_sandbox/x86_64/perl Makefile.PL PREFIX=/home/senaco5/perl/usr OTHERLDFLAGS=-L/usr/lib64 LDFLAGS=-L/usr/lib64 EXTRALIBDIR=/usr/lib64 -- NOT OK
Running make install
Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine prerequisites
perlmod--Install done

Would you tell me how to install it?

Thanks.
Thank you for your question ejbang!

Sorry for the trouble with the Apache::GeoIP modules not installing on your server. The available Perl modules are listed to show "Existing" modules; however, not all of the modules are supported on the Shared server platform. mod_perl will need to be installed on the server; unfortunately, this cannot be installed on our shared server environment. We do apologize for this. You can upgrade to a VPS or Dedicated server to have mod_perl installed. Sorry for the trouble.

Best Regards,
James R