Export Import Not working for Opencart

  • Answered

PLEASE HELP ME NOTHING SHOWING in my Opencart. 'System > Export/Import' will not show. I can see upto 'System > Backup/Restore'. (I have pasted the system information bottom of this details)

I am using opencart v
vQmod 2.1.6-Opencart
Shoppica 2 Theme + few other OC extensions (all extensions are working fine together)

I have tried few times on my different test sites (one of them has OC default template) but the 'System > Export/ Import' will not show in any one. I can see upto System > Backup/Restore.
I have selected 'tool/export' in both places from 'Top Administrator' - as per the instruction.

I have followed below links

Also read the readme from 'opencart-1-5-3-x-export-import-10'
NO LUCK AND then tried to modify the 3 files manually (header.php and header.tpl)

I have followed and tried to change manually:


After doing this manual change my front site comes up with tons of characters (possibly
php codes etc.)

PLEASE HELP me. Please see below the System Information (extracted via System Information v1.1 Tool)

System Information

System Information Value

Opencart Version :
Operating System : Linux box387.bluehost.com 2.6.32-20120131.55.1.bh6.x86_64 #1 SMP Tue Jan 31 15:43:27 EST 2012 x86_64
Web Server : Apache
Web Host Info : www.shopdiversity.com
MySQL Server Version : 5.1.63-community-log
MySQL Host Info : Localhost via UNIX socket
Root Path : /home2/shopdive/public_html
Full phpInfo : phpInfo

Setting Required Server Status
PHP Version >= 5.0 5.2.17
Safe Mode Off Off
Register Globals Off Off
Magic Quotes GPC Off On
Session Auto Start Off Off
Allow Url Fopen On On
File Uploads On On
Cookies On On

Extensions Required Current Status
GD On On
Curl On On
Fsock On On
Zip On On
Xml On On


Directories Permission Status
/store3/image/ 755 Writable
/store3/image/data/ 755 Writable
/store3/image/cache/ 755 Writable
/store3/download/ 755 Writable
/store3/system/cache/ 755 Writable
/store3/system/logs/ 755 Writable
/vqmod/vqcache/ 755 Writable

Files Permission Status
/store3/system/logs/error.txt 644 Writable
/vqmod/vqmod.log File Unavailable File Unavailable

Hello Att,

Without being able to actually log in and check specific things, it is hard to say. Being on another host makes that impossible. Also, have you reverted any of the changes you have made after ruling them out? There should be no file modification necessary for this to work.

It actually should show in the menu but simply give you permission errors as long as it installed properly even if you did not edit the Top Admin section. This leads me to believe something went wrong in the installation itself. You should also check the error log for good measure. It will not have any installation errors, but if the install did go right, it may have some clues for you.

After installing here and getting no errors, I would also advise to check with your hosting company to see if they can see anything on the server side or be able to assist. They may be able to walk through and duplicate it, thus troubleshoot the issue for you.

Best Regards,
Scott M