Joomla 3.1 SEF SEO Not Working

  • Answered
I have just transferred an existing website to my server - files and database. The only thing that has changed is the database password.

However the Joomla User friendly URL are no longer working. I see this issue has been raised before but no indication on how it was resolved.

I have double checked the .htaccess file and turned the settings on and off through the configuration setting in the admin panel but to no effect.

Please advise

Hello RogerM, Sorry for the problem with the Joomla SEF's not working. You said that you turned the settings off, but can you verify if the links are working with the option turned off? The URLs in the database should be updating and I can't determine if that's happening or not without first verifying if the links are working with the SEF url option turned off. Additionally, you will need to make sure that no caching has been left on from previous, as it may also be carrying over old URLs. Turn off caching and then turn off the SEF option (or extension) and verify that your links are working or not working. If they're not working, then it's NOT an SEF issue. At that point you would need to check your configuration and make sure that all paths are set correctly. After you have it working without caching or SEF turned on, you can go back and turn on these options. They should then work properly and your links should go back to being search engine friendly. If you have any further questions or comments, please let us know. Regards, Arnel C.