Error installing wp supercache per IMH instructions.

  • Answered
Permalink URL structures error. Whaaaa?
Cannot proceed without info. Please assist.

Hello and thanks for your question. When following our guide for WordPress WP Super Cache, I see that it doesn't mention it at the moment, but you need to enable Permalinks in WordPress in order for it to function properly. Without Permalinks your URL structure would look something like: The ?p=34 part is telling the WordPress index.php file that the p or page variable should be set to the page with an ID of 34. When you enable Permalinks your URL structure instead looks like: Because the URL is now a Permalink, that means we can cache the info on that page to one called problems-with-wp-super-cache.htm, and don't have to rely on a PHP script to execute again to process the ID that we passed it from the URL. This is essentially what WP Super Cache is doing in the background, and why it needs Permalinks enabled to work. To enable Permalinks in WordPress just:
  1. Hover over Settings, click Permalinks
  2. Select a format for your Permalinks, most common is Post Name

    Or define your own Custom Structure

  3. Click on Save Changes
Hope that helps, and thank you for sharing your issues. It looks like we need to update our documentation a bit and so I'll make sure to add this. - Jacob