Increase the max_input_vars in php.ini

Avatar
  • Answered
I am stuck with an error:
"Warning, your PHP configuration limits the maximum number of fields to post in a form: 1000 for max_input_vars.
Please ask your hosting provider to increase the this limit to 1318 at least or edit the translation file manually." when I try to alter some translations on my front Office. Is it possible to increase the max_input_vars from the 1000 default to 1500 ou 2000?
Duplicates 9
I cannot increase php_value max_input_vars on my server
hello Inmotionhosting!

I have my PHP runs on your server as Apache module. Therefore, I add this to my .htaccess:
php_value max_input_vars 5000
php_value suhosin.post.max_vars 5000
php_value suhosin.request.max_vars 5000
Unfortunately, the error 500 appears! please show me how to add the value to the .htaccess.
Also, I tried to create php.ini and add this:
max_input_vars = 2000
suhosin.post.max_vars = 2000
suhosin.request.max_vars = 2000
It is also not working.

please show me how to add the value.
Hi, I am having difficulties increasing the PHP Max Input Vars from the value of 1000 to 3000 with the php.ini file as after the change and saving, it doesn't reflect. I've cleared browser cookies and all but no change. Any help ?
php.ini and max_input_vars = 1000
Hello, I have a problem with prestashop, I would like to translate the website, but there is the limit 1000 for max_input_vars.
I made the file php.ini in /public_html, and wrote there max_input_vars = 4000, but nothing happened. Could you help please with this issue?
max_input_vars in php.ini must set to 7000
In order to support some RTL language , I need to set 'max_input_vars' in php.ini to 7000 instead of 1000
I' have got the below error from Prestashop 1.6.0.9
" Warning! Your PHP configuration limits the maximum number of fields allowed in a form
1000 for max_input_vars.
Please ask your hosting provider to increase this limit to 7000 at least,
or you will have to edit the translation files.
"
could you please help ?

PHP configuration number of fields - max_input_vars Error/change

[Pedro]


EMAIL:
DOMAIN:


QUESTION:


Good morning


There's a problem with my prestashop site.


When is was updating translations because i had errors and missing fields, i received the message


"Warning! Your PHP configuration is limiting the maximum number of fields allowed in a Form 1000 for max_input_vars.


Please ask your hosting provider to increase this limit to at least 4709 or change the translation file manually."


So can you please help me on this and solve this problem?


Best Regards,


Pedro

I can't increase the max_input_vars
When I try to translate installed modules on Prestashop, I get the error message:
"Warning! Your PHP configuration limits the maximum number of fields allowed in a form
4000 for max_input_vars.
Please ask your hosting provider to increase this limit to 6413 at least, or you will have to edit the translation files."
I made changes in php.ini directly and gave access to my back office to inmotion hosting support through the chat but they did not succeed either and told me to ask through community support.

Thanks in advance
Can I increase php_value max_input_vars on my server?
I have a website that list many products that I sell in my store. I use wordpress and Marketpress plugin to manage all the products, my problem occurs when I create a menu of categories and submenu of products under each catgory. The menu wont display and prevents the rest of the content from displaying as well. Researching this increasing my php_value max_input_vars to 5000 may work.
max_input_vars not setting correctly
When I try to modify front office translation , shows this note:
Warning! Your PHP configuration limits the maximum number of fields allowed in a form: 1000 for max_input_vars.
Please ask your hosting provider to increase this limit to 1138 at least, or you will have to edit the translation files.

But my max_input_vars is 2000. Please help!
My Wordpress theme requires max_input_vars in php.ini be set to 3000.

I edited the php.ini file in my www directory but the change does not take effect until I restart apache. How do i do that or can you? Thanks


Theme version 2.1.0
Product Registration Theme registered
Frontend Stylesheet ../wp-content/themes/uncode/library/css/
Backend Stylesheet ../wp-content/themes/uncode/core/assets/css/
WP Memory Limit 256 MB
PHP Max Input Vars 1000 - We recommend setting PHP max_input_vars to at least 3000. See: Increasing the PHP max vars limit
PHP Max Input Vars (allowed)
The effective maximum number of variables your server can use for a single function to avoid overloads. If this value is lower than max_input_vars your server is applying restrictions on the actual number of vars that can be used.
If you modified the server settings refresh the option to test.
1000 - We recommend setting PHP max_input_vars to at least 3000. More info  

Avatar
Arnel C
  • Answered

Hello Daniel,

Thanks for the question about restarting the Apache service.  It depends on your account subscription.  If you're on a shared server, then you will need to contact our live technical support team.  If you're on a VPS or Dedicated server, then click on the link and you'll several ways to restart the service.

I hope that helps to answer your question! If you require further assistance please let us know!

Regards,
Arnel C.

Avatar
Scott
Hello semjonova, Thank you for your question on editing the max_input_vars for your php settings. Please make sure set your php.ini file to be recursive or it will only work in the folder in which the file resides.
Avatar
Scott
Hello, Sorry to hear you are having issues changing your max_input_vars. Be sure that your php.ini file is set to be recursive. This way the change will be for all folders and files. Kindest Regards, Scott M
Avatar
johnpaulb-imhs1
Hello phammanhthang87, Thank you for contacting us about issues increasing your PHP settings on your server. Here is a helpful link to our helpful walk-through guide on How to Change PHP settings in your hosting account. That guide walks you through changing your PHP settings in your php.ini file, instead of your .htacess file. If you do not see a file named php.ini in your public_html, please contact our Support Department and request that we create one for you. You may have to make the PHP changes recursive, meaning it affects all child folders. You can confirm the PHP setting has changed with a phpinfo page. Let us know if you have any further questions. Thank you, John-Paul
Avatar
johnpaulb-imhs1
Hello, Thank you for your question about increasing the php_value max_input_vars. This is a PHP setting you can adjust in your cPanel at any time. This is covered in depth in our guide on how to Change PHP settings in your hosting account. If you have any further questions, feel free to post them below. Thank you, John-Paul
Avatar
Scott
Hello,

I have made sure you have a copy of the php.ini file in your account under the public_html folder. I went ahead and set the max_input_vars to 7000 for you. Feel free to edit that file at any time to adjust any of the settings you need for your account.

Kindest Regards,
Scott M
Avatar
JeffMa
We are happy to help. To adjust any PHP configuration settings, you would simply need to make a change to your php.ini file. For a tutorial on how to do so, take a look at the following: How to update your local php settings As this may need to be changed across your whole site, se sure to also make your php.ini file recursive as well.
Avatar
JeffMa
As the script that requires this to be enabled deeper within your directory structure, you may need to make your php.ini file recursive as by default, it only effects the directory that it is in. Also, here is a similar question we answered, where someone had to Increase the max_input_vars in php.ini, and make it recursive.
Avatar
johnpaulb-imhs1
Hello Andre_Sa, Thank you for your question regarding your PHP settings. Here is a link to an article in our support center titled "How to update your local php settings." This helpful article explains how to modify your PHP settings. If you have any further questions, feel free to post them below. Thank you, -John-Paul