Default firewall

Avatar
  • updated
  • Answered

Hello,


I am trying to enable ufw on a ubuntu vps however i find it inactive after reboot. I'm also not sure if the default vps configuration uses any other firewall tool.

Pinned replies
Avatar
Ronnie H.
  • Answer
  • Answered

Hello! I spoke to one of our Ubuntu specialists, and the best way to set this up would be to add ufw to init.d so that it automatically starts up with the server.  


sudo systemctl enable ufw

That should take care of it. Try that out, and let us know how it goes! 

Avatar
Ronnie H.

Thanks for letting us know how it went. Normally when adding items to the init.d file or files like it, you'll simply leave everything as is and add the new content to a new line at the bottom. That's OK though, if it's working now, there is no need to worry with it!

I ran your solution by our team, and it looks like the service was probably starting up after boot, but then exiting/crashing because Ubuntu was trying to use something else to look up iptables. 


Just to clarify, I'm only mentioning that so that you can note the information in case you need to do further troubleshooting later. There's no need for you to do anything extra if it's working! I just want to make sure that, if something happens later, you have a possible explanation and what to look for. I hope things continue to go smoothly. 

Avatar
ahmed alhindi

Unfortunately , I did not know what to do with ufw at init.d I found an existing file there and did not want to mess it up. However, I've followed this and it seems to remain enabled after restart https://devtidbits.com/2019/07/31/ufw-service-not-loading-after-a-reboot/

Hope it helps...

Cheers,

Avatar
Ronnie H.
  • Answer
  • Answered

Hello! I spoke to one of our Ubuntu specialists, and the best way to set this up would be to add ufw to init.d so that it automatically starts up with the server.  


sudo systemctl enable ufw

That should take care of it. Try that out, and let us know how it goes!