Cannot insert more than 2 images at a time into WordPress

  • updated
  • Answered

I am having an issue where, for any of our sites hosted on InMotion, we cannot insert more than 2-3 images at a time. This is really hampering, because we often publish blog posts with 50+ images. It doesn't matter whether it's the visual editor, or text editor. They upload fine, it's just on the insertion that it malfunctions.


The same sites on our previous hosting (we switched to InMotion a month or so ago) worked fine and we could insert all images. When I talked to support, they were actually able to insert more than 2-3 with no issues.


Any idea why this would be limited to just our connection to InMotion (apparently) and not the same on our other hosting? Or any ideas at all? It's really crippling to our publishing platform, and we will most likely have to switch hosting if we can't get a resolution with InMotion.

Arn
Hello, Our apologies for the issues that you're having with inserting images into your website. I tested by creating and admin user on my own WordPress site first, then going to your site (liveviewstudios.com) and testing there as well. You are using a non-standard WordPress editor - it's been replaced by something from a theme or plugin. I tested on my work connection to the internet AND I also went to my laptop and tethered to my iPhone and tested through my personal connection to the internet. Both worked with no issues. I was able to add multiple images - I was adding 6 at a time. This is not a server restriction, and we do not control your connection to the internet. I guess my main question to you would be what user you are using to add the images. I was using a user with Admin privileges. By the way, please delete all of the added administrators when you have a chance. Only your users should remain. I'm not sure how you are adding images, but these are my exact steps:
  1. Login to Admin as an administrator
  2. Click on Posts
  3. Click on Add New
  4. Click in the Editor to add some text, then make sure that I see that the cursor is blinking on the page
  5. Click on Add Media
  6. In order to select multiple graphic files, I hold down the shift-key while left-clicking on each image I wish to add.
  7. Click on Insert into Post
  8. When I finish the images are added into the post. I noticed that when I was working in your WordPress installation that there is no option for TEXT/VISUAL - which is the default editor used in WordPress. Instead, you have PageBuilder. If I click on PREVIEW, I do see the images I've added. Please compare your workflow to what I've done and let us know where you differ. We're not familiar with PageBuilder as it's a third-party application used to help you build your pages. It's possible that your limitations with images might be springing with your settings in that application. Please let us know if you're still having the same problem. If so, please provide more detail on the difference between our processing images and yours. If you are using the PageBuilder interface, you might be better off consulting with their support team to see if they have a different set of steps necessary for adding multiple images. If you have any further questions or comments, please let us know. Regards, Arnel C.
christopherm
Hello,

Thank you for your question about upload limits in your server. It is likely you are running into a limitation based on a shared hosting environment. This is just to make sure that other users have fair access to the resources. It sounds like your workflow requires a greater deal of resources at one time. This would be an ideal situation where a VPS environment would be more suitable. Or, you could consider using a plugin like the "Heartbeat Control" plugin.

Best,
Christopher M.