0
Answered

PrestaShop Product Not Showing After Migration frm subdomain to domain

InMotionFans 6 years ago in Ecommerce / Prestashop 15 0
I'm using PrestaShop 1.6.0.9. After it is migrated from shop.domain.com to domain.com, the Product does not load any image or data/details when I preview it . Although the data and images were still in the Catalogue and Product Modules. All other functions and pages of my PrestaShop seem to be working fine (After the migration and the Support Team helped to move the files to public_html) except the Product details not showing. I've tried the following measures but none worked:
1. Re-indexed data after migration. Log in to admin panel go to Preferences -> Search. Press Add missing products to the index button and then Re-build the entire index.
2. Opened the catalogue/product modules and re-saved the data
3. Deleted catalogue and products and re-created the product again
4. Used PrestaShop's Cleaner module to delete the catalogue/product data, fix and cleaned the database and
5. Reset the catalogue/product related modules under Modules, Modules - Configure and then recreated the product again
6. Also tried Advanced Parameter Caching - Enable and Disable
All that and the product still doesn't show when I preview the page. Please help.
Found error after Error Reporting is run. The problem disappears after clearing the web browser's cache.
Hello,

Unfortunately with your shop in the maintenance state I am unable to check out the issue. I did set up a test on my own server and moved a shop from shop.example.com to example.com. I did not experience any issues, however, so I cannot guess as to what the issue may be at this point. I did check your database to ensure that the same fields that were changed in my own test were also correct in yours. They seem to be set correctly.

If you could remove the maintenance mode so we can test I may be able to take a look at the behavior and get a better grasp on the situation for you.

Kindest Regards,
Scott M