WP temp URL doesn't work

  • Answered
I have transferred my WP blog to my new account into a sub-directory like it was at my old site. I've added the "define" code to the wp-config file.

The temp URL works for the home page, but nothing else. The old posts don't show up, and the (relative) links don't work. They just go to the default Inmotion page.
Hello Pdmar, You may want to try and reset your Permalinks within the WP dashboard. To do that simply set them back to default, save, then set them back to the settings you had, then save again. This may help. Setting the Define setting in the wp-config is not the best method. Wordpress is very tied to the domain name and does not work well with temp URLS, but if you absolutely must do so, the best method is to do a hosts file modification on your computer. You can see how to do that here if you are on a PC or here if you are on a Mac. Be sure you have the correct subdomain created on your account and create the specific full subdomain in the hosts file. You can then remove the define lines from the wp-config and this should work. Once you have pointed the domain name to the server, you can remove the hosts file mod. I hope this answers your question. If you have any more questions or information specific to the issue please leave a comment below so we can further assist you. Best regards, Scott M.