website files do not load to public_html

  • Answered
I am using serif webplus x8 and with previous hosting I had it configured fine and configured it the same with inmotion. Now I upload files for primary domain to public_html and it installs in folder public_html/psyche - same as previous provider. But then I get a file index page instead of the web page. I can get the webpage fine if I move the files to out of the folder /psyche to root public-html but I cannot install them there from webplus as the server always asks to create a folder. Hope that's clear (enough). I've read your help files and tried endless options but no luck. Please advise. I have 2 other small websites to install.
Thanks, have tried endless permutations including using psyche10 instead of and also tried what was on the serif forum - but still get 421 error. The only way I can get it to load is to first create folder public_html/psyche then when WPX8 ftp uploads it asks to create a folder /psyche then the files upload OK to public_html/psyche/psyche. If I them move the files to the root public_html everything is as it should be. It seems to be acting like a subdomain, wanting its own directory not the primary domain. The problem seems to be with the ftp settings in WPX8 not working with inmotion's settings. Any other suggestions?
Hello, Sorry to hear that you're having problems with the Serif Webplus x8 software uploading your websites. The primary domain (the one you used to register your account) is saved in the public_html folder by default. It should not be in another folder such as the one you have named "psyche". All of the files inside the "psyche" folder should be in the public_html folder. That is normal behavior for installations on InMotion servers. You can have the document root changed via a support ticket, but default behavior will mean that all files need to be in the root of the public_html folder by default. All other website installations on the server can be placed in a folder using an add-on domain. You can designate the folder for these websites, but the folder resides under the public_html folder. I hope that helps to explain the issue you're seeing. If you have any further questions or comments, please let us know. Regards, Arnel C.