Why is my home page displaying as an index list only?


pawpawspilotcar
Asked:
2012-01-30 5:20 pm EST

Hits: 18,131
I have uploaded all of my files for my website. I don't have an index file that I can find (index.htm or index.html). When I type in my domain name, I see a page titled "Index of /" that lists each of the files used to create my website. Can anyone tell me how to fix this?

You must login before you can ask a follow up question.

You must login before you can submit an answer.

OTHER ANSWERS

0

BradM
Staff
5,388 Points
2012-01-30 5:37 pm EST
Hi pawpawspilotcar,

When someone tries to load your website and does not manually type in a file name (such as index.php or index.html), the server attempts to load the "directory index". The directory index is a listing of files it should load.

For example, if you type in domain.com (IE not domain.com/index.php), the server will attempt to load files in the following order. If a file is not found, then it tries to load the next file in the list:

http://domain.com/index.html
http://domain.com/index.htm
http://domain.com/index.php

... and finally, if your server does not find any of these files, it then simply returns a listing of all of the files in the directory.

If you have a homepage called something other than index, such as welcome.html, edit your .htaccess file and add this line to tell the server to load this file first:

DirectoryIndex welcome.html index.html index.htm index.php


To answer your question:
If you do not want the server to return a listing of all the files, you can disable this feature within your cPanel.

1. Log into your cPanel. cPanel is included with all of our accounts, including our dedicated servers.
2. Find and click on the icon that says "Index Manager" (should be at the bottom of cPanel)
2B. If you get a pop up message, choose "web root" and then click "Go"
3. Navigate to the folder that you want to adjust this value for. Click the folder icon to go into the folder, and click the actual folder name to select that folder and make changes for it
4. Select "No Indexing" to hide the file names, or select "Standard" or "Fancy" indexing to list them and then click "Save"

Please be aware that when you make a change here, it will affect all subfolders as well. For example, if you set "No Indexing" for your public_html directory, then it will apply the setting to all folders within your public_html (so that you don't have to manually make this change to every folder).


For more details on directory index (referred to above), please see:
What directory should I put my files in?

I hope this helps! If you have any questions, feel free to post a comment on this page and I'll be happy to help further.

Thanks!
- Brad

You must login before you can post a comment about this answer.

Hi
I am new to webhosting,i am also facing the same issue "Home page displaying as an index list only?",I would like to know that what is this cPanel, i am using godaddy server,In godaddy what we can do to solve this issue
Rasiya
3 Points
2014-04-22 7:37 am EST
cPanel is a hosting control panel that is used by us, as well as the majority of hosts across the world. It is used to manage your hosting account.

If you are hosting with GoDaddy, I won't have specifics as to how you can solve the problem, but in most cases it is simply because you do not have the correct file name for your index file. The name of your index file should be something like index.html or index.php. If you don't have a file named index, this would be why you are seeing this.
JeffMa
7,372 Points
Staff
2014-04-22 8:05 am EST
Like this Question?

Need more Help?

Search

Ask the Community!

Get help with your questions from our community of like-minded hosting users and InMotion Hosting Staff.

Current Customers

Chat: Click to Chat Now E-mail: support@InMotionHosting.com
Call: 888-321-HOST (4678) Ticket: Submit a Support Ticket

Not a Customer?

Get web hosting from a company that is here to help. Sign up today!