I need a different version of PHP/MySQL

If for some reason you cannot install programs on your server like Joomla, Drupal, WordPress, etc. and you are getting PHP errors on your site because of the PHP or MySQL version, you can have InMotion Hosting tech support move or upgrade your account.

Shared server environment

We have shared servers with various versions of PHP and MySQL, so it’s very likely that we have a server that runs the version(s) you are looking for. You can change the version of php for your account within the cPanel. In order to provide stability and quality service to current customers, we rarely make changes to the PHP and MySQL environment of shared servers, but we are able to move your account to a different server if we have a server that meets your version needs.

Please note! that some servers may not be able to accommodate your account for various reasons.

VPS and Dedicated servers

Most Virtual Private Server and Dedicated Server customers can request an upgrade/downgrade of PHP and/or MySQL. Please contact our support department if you are in need of different versions. If you are looking for a low cost VPS solution, click here to read more.

Note! We do not currently have “hybrid” servers that run both PHP 4 and PHP 5. This setup is only available on VPS and Dedicated server running Apache 2.0 or higher, by request. You can read about the differences between VPS and dedicated servers here.

Was this article helpful? Let us know!