PHP unable to load dynamic PDO libraries and htscanner after upgrade to PHP 5.4

  • Answered
Hi, I am on a shared server and was using the default PHP 5.3. I decided to go ahead an update to 5.4 (via Cpanel's php configuration). Now I get this error (repeated over and over) in the error log:

"[14-Aug-2012 15:32:28 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/pdo.so' - /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/pdo.so: undefined symbol: zend_new_interned_string in Unknown on line 0
[14-Aug-2012 15:32:28 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/pdo_mysql.so' - /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/pdo_mysql.so: undefined symbol: mysqlnd_allocator in Unknown on line 0
[14-Aug-2012 15:32:28 UTC] PHP Warning: PHP Startup: htscanner: Unable to initialize module
Module compiled with module API=20100525
PHP compiled with module API=20090626
These options need to match
in Unknown on line 0"

Should I just comment out the lines in the php.ini file that tell php to load those, or will that disable PDO (which I use)?? Or is this something that IMH needs to fix?

Thanks.
Arn
Hello JdGrimes,

I spoke with a T2c who advised that you simply rename your PHP.INI to fix the problem. If you know what needs to be removed you can also edit the PHP.INI file directly.

If you have any further questions, please contact technical support or leave a comment at the bottom of the page.

Regards,

Arnel C.