I am getting this error message: error/An error occurred whilst communicating with the server, whenever I click on the link of my embedded pages in my moodle website. How can I fix it please

  • updated
  • Answered

I am an IT officer.

Pinned replies
Ronnie H.
  • Answer
Quote from Oluwaseun

Hello InMotion Support,

This is the error that I got when turned on debugging mode on my moodle website:

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/dexnovac/public_html/abs/terms_of_engagement/index.php:1) in /home/dexnovac/public_html/abs/lib/classes/session/handler.php on line 42

error/An error occurred whilst communicating with the server

Debug info:
Error code: An error occurred whilst communicating with the server
$a contents:

Stack trace:

  • line 79 of /lib/classes/session/manager.php: core\session\exception thrown
  • line 785 of /lib/setup.php: call to core\session\manager::start()
  • line 27 of /config.php: call to require_once()
  • line 7 of /terms_of_engagement/index.php: call to require()

How do about this errors because I do not understand.

Regards

Hi Oluwaseun! Unfortunately, we're getting into territory that may require you to talk to a PHP or Moodle developer. There are two things I would suggest trying though: 

First, change the version of PHP you are using. Try the latest, and see if that fixes the issues. If not, try the oldest version available. If that works, move up more recent versions, one at a time, until things stop working-- then go back to the most recent workable version. 

That's the most likely issue in my estimation. Sometimes, cPanel updates can end up changing the currently used version of PHP. 

If that does not help, I found some discussion in Moodle forums indicating that the problem can happen when the starting tags of PHP code are in the wrong place. If you recently edited the code yourself, or copy-pasted code from another source, I would check this. If you did not edit the code recently, though, I would avoid trying now-- this usually only happens when you manually edit the code!

I hope those suggestions help. If not, you may want to reach out to our 24/7 Live Support team, since they can connect to your account directly and take a closer look.

Ronnie H.
  • Answer
Quote from Oluwaseun

Hello InMotion Support,

This is the error that I got when turned on debugging mode on my moodle website:

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/dexnovac/public_html/abs/terms_of_engagement/index.php:1) in /home/dexnovac/public_html/abs/lib/classes/session/handler.php on line 42

error/An error occurred whilst communicating with the server

Debug info:
Error code: An error occurred whilst communicating with the server
$a contents:

Stack trace:

  • line 79 of /lib/classes/session/manager.php: core\session\exception thrown
  • line 785 of /lib/setup.php: call to core\session\manager::start()
  • line 27 of /config.php: call to require_once()
  • line 7 of /terms_of_engagement/index.php: call to require()

How do about this errors because I do not understand.

Regards

Hi Oluwaseun! Unfortunately, we're getting into territory that may require you to talk to a PHP or Moodle developer. There are two things I would suggest trying though: 

First, change the version of PHP you are using. Try the latest, and see if that fixes the issues. If not, try the oldest version available. If that works, move up more recent versions, one at a time, until things stop working-- then go back to the most recent workable version. 

That's the most likely issue in my estimation. Sometimes, cPanel updates can end up changing the currently used version of PHP. 

If that does not help, I found some discussion in Moodle forums indicating that the problem can happen when the starting tags of PHP code are in the wrong place. If you recently edited the code yourself, or copy-pasted code from another source, I would check this. If you did not edit the code recently, though, I would avoid trying now-- this usually only happens when you manually edit the code!

I hope those suggestions help. If not, you may want to reach out to our 24/7 Live Support team, since they can connect to your account directly and take a closer look.

Oluwaseun
Quote from Arnel C

Hello Oluwaseun,

Sorry for the error you're getting when using Moodle.  You need more information about the error and the best thing to do is to turn on debugging to help you identify the source of the problem.  This issue is discussed on a Moodle site post.  You may able to get more help through the Moodle community once you provide more information about the specific error.


If you have any further questions or concerns, please let us know!

Kindest Regards,
Arnel C.

Hello InMotion Support,

This is the error that I got when turned on debugging mode on my moodle website:

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/dexnovac/public_html/abs/terms_of_engagement/index.php:1) in /home/dexnovac/public_html/abs/lib/classes/session/handler.php on line 42

error/An error occurred whilst communicating with the server

Debug info:
Error code: An error occurred whilst communicating with the server
$a contents:

Stack trace:

  • line 79 of /lib/classes/session/manager.php: core\session\exception thrown
  • line 785 of /lib/setup.php: call to core\session\manager::start()
  • line 27 of /config.php: call to require_once()
  • line 7 of /terms_of_engagement/index.php: call to require()

How do about this errors because I do not understand.

Regards

Arnel C
  • Answered

Hello Oluwaseun,

Sorry for the error you're getting when using Moodle.  You need more information about the error and the best thing to do is to turn on debugging to help you identify the source of the problem.  This issue is discussed on a Moodle site post.  You may able to get more help through the Moodle community once you provide more information about the specific error.


If you have any further questions or concerns, please let us know!

Kindest Regards,
Arnel C.