I am having SSL certificate and also installed the plugin called really simple SSL and still i am not able to convert from http to https in settings. It is showing a grey box where i am not able to edit anything. Why is it happening so?? Plz help me out .

Avatar
  • updated
  • Answered
Pinned replies
Avatar
Alyssa K
  • Answer

Hello Deepak, 


Thank you for your question regarding SSL certificates. Unfortunately, without more information, it is difficult to troubleshoot this issue. If the option to edit the site URL is grayed out, that likely means your account does not have the required permissions to modify that information, or there is a plugin interfering with your ability to modify the site URL. I recommend disabling any security or SSL related WordPress plugins before attempting to modify the site URL. 

Best Regards, 

Alyssa K. 

Avatar
JT S.
Quote from Deepak Kirtania

yes i have installed the SSL certificate from cloudflare by changing the DNS servers in wordpress and it is also showing a lock symbol before my website name...but when i am opening dashboard->general->then there are 2 options called wordpress site and url site where and there it is written http://domain. I am not able to convert it to https because it is not letting me to type anything. Its disabled..why is it happening

I recommend creating a backup before checking your Really Simple SSL settings, particularly the WordPress 301 settings.

Avatar
Alyssa K
  • Answer

Hello Deepak, 


Thank you for your question regarding SSL certificates. Unfortunately, without more information, it is difficult to troubleshoot this issue. If the option to edit the site URL is grayed out, that likely means your account does not have the required permissions to modify that information, or there is a plugin interfering with your ability to modify the site URL. I recommend disabling any security or SSL related WordPress plugins before attempting to modify the site URL. 

Best Regards, 

Alyssa K. 

Avatar
Deepak Kirtania
Quote from JT S.

Hello and thanks for contacting us. Have you installed an SSL certificate already? Can you specify what shows as a grey box?

yes i have installed the SSL certificate from cloudflare by changing the DNS servers in wordpress and it is also showing a lock symbol before my website name...but when i am opening dashboard->general->then there are 2 options called wordpress site and url site where and there it is written http://domain. I am not able to convert it to https because it is not letting me to type anything. Its disabled..why is it happening

Avatar
JT S.
  • Answered

Hello and thanks for contacting us. Have you installed an SSL certificate already? Can you specify what shows as a grey box?