SSL Is Securing All Pages, Except for Admin Area, Urgent Help Needed!

  • Answered
I am using CrazyDomains for my website: https://megagrocery.com.au, after activating SSL, home page and all product pages are secure, but when I go to https://megagrocery.com.au/admin it won't let me in. The lock sign appears like a flush and disappears. This also happens when I go to customer register page all links in the box such as login, register, forgotten password, newsletter etc that is created for customer are insecure.
I have already forced http to https in both config.php files, I have also written the following htaccess code:
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://megagrocery.com.au/$1 [R,L]
to force all http to https within the website. I still fail to understand where the problem is.
Please note that when I see the source code on admin login, I notice a couple of http urls, but because I have built the website in opencart, using PHP, I can't locate those urls so that I could either hard code them or if you know the code to fix this issue, please let me know. It has been hassling me for days, thank you so much for your time guys!
Scott
Hello JamesAsh, Sorry to hear you are having issues with your OpenCart displaying in https properly. Does it fully redirect back to http or does it show https but say it is not secure? If you follow our guide on enabling SSL on OpenCart 1.5 (assuming 2.x is the same) it should use https without any issues. Other than that, you may need to use the development tools in your browser to see if it gives any clues on why the https is not displaying. Does it fully redirect back to http or does it show https but say it is not secure? This will do well if the https is in the URL but it says it is not secure. Kindest Regards, Scott M