Woocommerce/PHP Version Issue on Dedicated Server

  • Answered
Hello,

One of the sites on our dedicated server (labargemedia.com) needs to have it's Woocommerce version updated (the site with problems is christianvideowarehouse.com). It's currently at 2.0 and needs to go to at least 2.4 to be able to be compatible with our Authorize.net CC processing plugin (which needs to be updated to be compatible with the new Akamai url scheme).

However, updating Woocommerce to the most recent version results in a blank white page when visiting the website. We're currently running PHP v5.3 on the server, and I know Woocommerce recommends 5.4 or newer. We have a PHP switcher on our Cpanel, but changing that to PHP 5.4 results in 500 Errors on all of the sites on that Cpanel. I'm not sure why that would effect a couple of the sites that are not ecommerce sites and have no unique plugins or setups. The only thing that brings the sites back up is rolling back to PHP 5.3. However, this prevents us from updating Woocommerce.

Please help! We really need to get the Authorize.net plugin updated to continue processing CC payments...but all of these other issues seem to be preventing that.

Thanks!
johnpaulb-imhs1
Hello, Thank you for your question regarding WooCommerce issues with the PHP version of your server. Here is a link to our guide on Using multiple PHP versions on one account. Alternately, since you're on a Dedicated Server you could move the websites to separate cPanel accounts. If you have additional issues with your site, I recommend following our WordPress Troubleshooting guide. Thank you, John-Paul