Quotation marks (") often replaced with question marks (?) wordpress

  • Answered
After migrating my wordpress site from another host to inmotion, I noticed quotation marks (") are often replaced with question marks (?). This happens randomly throughout the site. I didn't make any changes to any of the files. Also I have some URL's that also had quotation marks and worked just fine with my old host but now are replaced with %e2%80%b3. Seems like some kind of encoding problem. Any idea how to fix?
Hello, Thanks for the question and sorry for the problems with the migration. This issue typically happens when a host server has a different collation set up for the MYSQL server than the new one you are migrating to. We do have a solution that should help. Please go through this tutorial on how to Change your WordPress database collation. The InMotion Hosting MySQL servers are setup with the normal connection collation setting of utf8_general_ci. I also found this same discussed in the WordPress forums. The resolution that is suggested can help you clean up any characters that aren't corrected. Here's the link to the forum post. I hope that helps to resolve the problem! If you have any further questions, please let us know. Regards, Arnel C.