WordPress media uploads displaying 403 error page

  • Answered
It seems all new media (picture) uploads on my WordPress blog are appearing as broken links. This started happening before I upgraded to version 3.8.1 but I didn't have a chance to address it.

When I try to access the uploaded picture directly, I come to a "Error 403 - Forbidden" page. Here is an example:
http://thatlovesong.com/?attachment_id=865

The strange part is, previously uploaded pictures unaffected; I do not come to a 403 error page. Here is the last uploaded picture before I started running into the 403 error (uploaded 11/18/2013):
http://thatlovesong.com/blog/2013/11/hope-for-the-dreamer/img_0128/

What have I done so far?
I checked the upload path folder (i.e. media) permission to ensure they are 750 and file permissions were 644.
I removed hotlink protection from the cPanel but that hasn't resolved the issue either.

Would you be able to help?
JacobIMH
Hello standardtoaster, and thanks for your question. I was unable to recreate a 403 error on the ?attachement_id=865 page. Have you recently moved WordPress from a sub-folder to the root directory, or changed the Permalink settings? It would appear that your WordPress installation is off by a directory in some cases. The media files for your WordPress website reside in:
/public_html/media/2014/
However, it looks like from the website you're trying to call them from the directory:
/public_html/blog/media/2014/
At least I gathered this from the only requests I see in your access logs that are causing 403 errors.
[11/Feb/2014:10:16:54 -0800] "GET /media/2014/02/bestillandknow.jpg HTTP/1.1" 403
[11/Feb/2014:10:18:40 -0800] "GET /media/2014/02/bestillandknow.jpg HTTP/1.1" 403
If you'd like for us to take a closer look, please let us know URLs that you are having issues with, not ones that are working. For instance your /hope-for-the-dreamer/img_0128 URL, what is suppose to be the next one? As I don't see a img_0127 or a img_0129 one. - Jacob